ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Per Hermansson (JIRA)" <j...@apache.org>
Subject [jira] Created: (IVY-779) resolve fails to put metadata in cache
Date Tue, 18 Mar 2008 19:57:24 GMT
resolve fails to put metadata in cache
--------------------------------------

                 Key: IVY-779
                 URL: https://issues.apache.org/jira/browse/IVY-779
             Project: Ivy
          Issue Type: Bug
          Components: Ant
    Affects Versions: 2.0.0-beta-2, 2.0.0-beta-1
         Environment: Windows XP, Java 1.6, Ant 1.7
Ubuntu, Java 1.5, Ant 1.6.5
            Reporter: Per Hermansson
         Attachments: output-beta2.log, sample-project.tar

Ivy fails to put module metadata in cache resulting in incomplete artifact retrieving.
I've created a sample project containing two modules, a and b. Module a depends on b (both
modules has a single artifact a.jar and b.jar).
With the following ant build file:
	<target name="test">
		<ivy:cleancache />
		<ivy:resolve file="repository/a/ivy.xml" />
		<ivy:retrieve ivypattern="output/[module]/[artifact].[ext]" pattern="output/[module]/[artifact].[ext]"
 />
	</target>

The following happens using Ivy 2.0.0-beta2:
Ivy gives a warning that it failed to put ivy.xml for module b in cache.
Later during the retrieve step only the artifact b.jar is copied to the destination folder
and not any of the following: a.jar nor the ivy files for module a and b.

When using Ivy 2.0.0-beta1:
The resolve step gives the same warning.
Then the build fails during the retrieve step because Ivy can't find the ivy.xml file for
module b in the cache.

This is probably another bug (or a feature?) since Ivy isn't failing the retrieve step when
the ivy.xml file isn't found.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message