ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 33260] p4change task does not set p4. change property correctly
Date Wed, 26 Mar 2008 10:23:05 GMT

Daniel Dräs <> changed:

           What    |Removed                     |Added
                 CC|                            |

--- Comment #5 from Daniel Dräs <>  2008-03-26 03:23:04 PST ---
I have the same problem here. Setup is as follows:

Perforce client:
Perforce - The Fast Software Configuration Management System.
Copyright 1995-2007 Perforce Software.  All rights reserved.
Rev. P4/NTX86/2007.2/122958 (2007/05/22).

Perforce server:
Server date: 2008/03/26 10:23:12 +0000 GMT
Server version: P4D/LINUX26X86_64/2007.3/143793 (2008/01/09)

My Ant task looks as follows:
        <target name="update_manifest">
                <property name="p4.globalopts" value="-P xxxxxxxx"/>
                <property name="p4.client" value="zzzz"/>
                <property name="p4.user" value="yyyyyy"/>
                <property name="p4.port" value="host:1667"/>
                <property name="p4.change" value=""/>

                <p4change description="Change Build Number in Script"/>
                <echo message="changeno: ${p4.change}"></echo>
                <echo message="changeno: ${p4.change}"></echo>
                <p4submit change="${p4.change}" globalopts="${p4.globalopts}"/>

This does unfortunatly not work. The p4change-command does not set the
p4.change-property as it should the echo reads as:
[echo] changeno: 

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.
View raw message