ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (IVYDE-68) IvyDE is using some internal classes of Eclipse
Date Thu, 03 Jan 2008 09:44:33 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-68?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12555518#action_12555518
] 

Xavier Hanin commented on IVYDE-68:
-----------------------------------

@Nicolas:
I've applied your patch with some modifications:
- in IvyClasspathContainer, I've only applied the change about the usage of internal eclipse
classes, since I already did the change for the cache management myself. BTW, I'm impressed
how fast you catch up with the cache management changes in Ivy!
- in IvydeContainerPage, I had to make minor changes to how Status object are created/obtained,
to make it compatible with eclipse 3.2

That's all, thanks a lot for this worthy and very clean contribution!

@Markus:
Thanks for your contribution, but I can't review your patch easily, too much diff. This is
probably due to changes in white space chars, could you try to update to latest version and
make only the change you did?

@all:
The FixedJavaSearchPage is a problem to maintain, and since it has never been documented and
is probably not that much useful, I think we could remove it. WDYT?

> IvyDE is using some internal classes of Eclipse
> -----------------------------------------------
>
>                 Key: IVYDE-68
>                 URL: https://issues.apache.org/jira/browse/IVYDE-68
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 1.3.0
>            Reporter: Nicolas Lalevée
>         Attachments: IVYDE-68-r607532.patch, ivyde.diff
>
>
> Some classes in IvyDE use come classes which are in some {{org.eclipse....internal...
}} packages, which should not be used. Compiling IvyDE with Eclipse 3.3 raise warning like
:
> {quote}
> Discouraged access: The method containerPut(IJavaProject, IPath, IClasspathContainer)
from the type JavaModelManager is not accessible due to restriction on required library /Users/nicolas/tools/eclipse-3.3/plugins/org.eclipse.jdt.core_3.3.1.v_780_R33x.jar
ivyde/src/java/org/apache/ivyde/eclipse/cpcontainer	IvyClasspathContainer.java	{quote}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message