ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] Commented: (IVY-706) The bundle packaging of Ivy is incorrect
Date Fri, 18 Jan 2008 16:25:33 GMT

    [ https://issues.apache.org/jira/browse/IVY-706?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12560453#action_12560453
] 

Nicolas Lalevée commented on IVY-706:
-------------------------------------

I have no strong opinion about dependencies management with OSGI bundle. I just know that
having the jar embedded evict the library version management issues, especially with xerces.
On the other side we loose the flexibility.

In fact I did this patch to make easier for Eclipse beginner to start playing with IvyDE with
the sources. Probably it is IvyDE that should embed these jars. So people who wants to build
IvyDE trunk can do it directly without configuration editing. And keep Ivy as a light bundle.

But this bug could not be closed as invalid because the {{Import-Package}} declarations are
need, aren't they ? (I am more an Eclipse player than an OSGI-spec reader)


> The bundle packaging of Ivy is incorrect
> ----------------------------------------
>
>                 Key: IVY-706
>                 URL: https://issues.apache.org/jira/browse/IVY-706
>             Project: Ivy
>          Issue Type: Bug
>    Affects Versions: 2.0.0-beta-2
>            Reporter: Nicolas Lalevée
>            Priority: Minor
>         Attachments: IVY-706-r612799.patch
>
>
> Ivy has recently been packaged as an OSGI bundle by adding a MANIFEST.MF. But it is not
correct since the runtime jars are not declared in the manifest.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message