ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bantling <gregh...@bantling.me>
Subject Spring boot thymeleaf 3
Date Tue, 06 Jun 2017 19:03:56 GMT
Hello.I want to use Spring boot and Thymeleaf 3 with Ant+Ivy. Spring boot
1.5.3 (current release) by default loads older thymeleaf 2. Apparently, the
solution in a Maven POM is to specify the following properties: 
3.0.2.RELEASE  2.1.1See  for reference.I tried setting these as Ant
properties before getting Ivy running, it makes no difference. I can use
override in my dependencies to bring in version 3, but then it doesn't work,
the code in spring boot is expecting version 2. I tried the following
overrides:
<https://github.com/spring-projects/spring-boot/blob/v1.5.3.RELEASE/spring-boot-samples/spring-boot-sample-web-thymeleaf3/pom.xml>
I'm not sure how those Maven properties actually get used when pulling
dependencies, I only know basics of Maven usage.Can anyone help me with
this? Can't seem to find or figure out the solution.



--
View this message in context: http://apache-ivy.996301.n3.nabble.com/Spring-boot-thymeleaf-3-tp9959.html
Sent from the ivy-user mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message