ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID" <dk0...@att.com>
Subject Why isn't ivy retrieving an artifact from repo?
Date Fri, 07 Feb 2014 17:44:24 GMT
I've had a prototype Ivy build working reasonably well.  I just looked at it today and I'm
seeing that it's finding an artifact on my intranet repo but not downloading it to the local
cache or retrieving it in my local build, which causes the build to fail.

The build specifies several other dependencies, most of which are found on mavencentral, and
one in another repo in the same local intranet repo that it's finding (but not downloading)
the other artifact.

I've tried a few times to clear out the ivy cache and run this again, but it downloads all
of the artifacts except for this particular one.

First, here is the relevant output from the build, with some minor pieces elided:
----------------------
install-dependencies:
:: Apache Ivy 2.3.0 - 20130110142753 :: http://ant.apache.org/ivy/ ::
:: loading settings :: file = <pathtoivysettingsxmlfile>
:: resolving dependencies :: com.att.ecom.poc#coherence_poc;working@<hostname> [not
transitive]
	confs: [default]
	found com.att.ecom.poc#poc-domain-model;0.0.1-SNAPSHOT in mavenCentralSnapshots
	found org.apache.commons#commons-lang3;3.1 in central
	found org.springframework#spring-aop;4.0.0.RELEASE in central
	found org.springframework#spring-beans;4.0.0.RELEASE in central
	found org.springframework#spring-context;4.0.0.RELEASE in central
	found org.springframework#spring-core;4.0.0.RELEASE in central
	found org.springframework#spring-expression;4.0.0.RELEASE in central
	found org.springframework#spring-web;4.0.0.RELEASE in central
	found com.oracle.coherence#coherence;12.1.2-0-0 in mavenCentralThirdparty
:: resolution report :: resolve 351ms :: artifacts dl 8ms
	---------------------------------------------------------------------
	|                  |            modules            ||   artifacts   |
	|       conf       | number| search|dwnlded|evicted|| number|dwnlded|
	---------------------------------------------------------------------
	|      default     |   9   |   0   |   0   |   0   ||   8   |   0   |
	---------------------------------------------------------------------
:: retrieving :: com.att.ecom.poc#coherence_poc
	confs: [default]
	0 artifacts copied, 8 already retrieved (0kB/5ms)
----------------------

The repositories "mavenCentralSnapshots" and "mavenCentralThirdparty" are actually on our
local intranet repo (which is also confusedly called "maven central").

Notice that it says there are 9 modules, but only 8 were downloaded.  The first artifact in
the list, "poc-domain-model" is the one that is not being downloaded, but I don't see why.

Here is my "ivysettings.xml" file:
-----------------------------
<ivysettings>
    <settings defaultResolver="default"/>
    <property name="m2-pattern" value="${user.home}/.m2/repository/[organisation]/[module]/[revision]/[module]-[revision](-[classifier]).[ext]"
override="false" />
    <resolvers>
        <chain name="default">
            <filesystem name="local-maven2" m2compatible="true" >
                <artifact pattern="${m2-pattern}"/>
                <ivy pattern="${m2-pattern}"/>
            </filesystem>
            <ibiblio name="mavenCentralSnapshots" m2compatible="true"
		     root="http://<hostandport>/nexus/content/repositories/cditspoc-snapshots"/>
            <ibiblio name="mavenCentralThirdparty" m2compatible="true"
		     root="http://<hostandport>/nexus/content/repositories/cditspoc-3rd-party"/>
            <ibiblio name="central" m2compatible="true"/>
        </chain>
    </resolvers>
</ivysettings>
-------------------------

And here is my "ivy.xml":
--------------------
<ivy-module version="2.0">
  <info organisation="com.att.ecom.poc" module="coherence_poc"/>
  <dependencies>
    <dependency org="com.att.ecom.poc" name="poc-domain-model" rev="0.0.1-SNAPSHOT"/>
    <dependency org="org.apache.commons" name="commons-lang3" rev="3.1"/>
    <dependency org="org.springframework" name="spring-aop" rev="4.0.0.RELEASE"/>
    <dependency org="org.springframework" name="spring-beans" rev="4.0.0.RELEASE"/>
    <dependency org="org.springframework" name="spring-context" rev="4.0.0.RELEASE"/>
    <dependency org="org.springframework" name="spring-core" rev="4.0.0.RELEASE"/>
    <dependency org="org.springframework" name="spring-expression" rev="4.0.0.RELEASE"/>
    <dependency org="org.springframework" name="spring-web" rev="4.0.0.RELEASE"/>
    <dependency org="com.oracle.coherence" name="coherence" rev="12.1.2-0-0"/>
  </dependencies>
</ivy-module>
---------------------

Is it obvious what my problem is, or is there something I can do to get more information?

Mime
View raw message