ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rodrigue ..." <rlag...@googlemail.com>
Subject Re: the credentials tag in ivysettings.xml
Date Fri, 09 Aug 2013 12:56:19 GMT
OK I see may this is the difference between out both settings. We are using
eclipse, and want it to work from there using the ivy eclipse plugin.

Somehow I have the feeling that the credentials tag is not considered when
working from eclipse




On Fri, Aug 9, 2013 at 12:23 PM, <Jonathan_Oulds@mcafee.com> wrote:

> We don't use Eclipse, artefact retrieval / publication is done via a
> framework of Ant tasks that wrap each modules native build script.
>
> We use a standard Ant 1.8.2 install with the Ivy 2.3.0 jar.
>
>
> Regards
>
> Jonathan Oulds
>
>
>
> -----Original Message-----
> From: Rodrigue ... [mailto:rlagoue@googlemail.com]
> Sent: 09 August 2013 07:49
> To: ivy-user@ant.apache.org
> Subject: RE: the credentials tag in ivysettings.xml
>
> Hello Jonathan,
>
> First thank you for your answer. It gives me a little bit hope :-)
>
> To have it working for you, did you need to download this http-component
> library?
> Are you using eclipse as IDE?
>
> Have a nice day
> Rodrigue
> On 8 Aug 2013 17:17, <Jonathan_Oulds@mcafee.com> wrote:
>
> > We also use the credentials tag to enable repository authentication
> > over http or https.  The server hosting our Ivy repository exposes an
> > ivysettings file with the credential tag e.g.:
> >
> >     <credentials host="ivyrep.server.com"
> >                  realm="Artifactory Realm"
> >                  username="${ivyrep.username}"
> >                  passwd="${ivyrep.password}"/>
> >
> >     <resolvers>
> >         <url name="ivyrep-shared"
> >              m2compatible="false"
> >              checkmodified="true">
> >             <artifact pattern="
> > https://ivyrep.server.com/artifactory/shared/....."/>
> >             <ivy      pattern="
> > https://ivyrep.server.com/artifactory/shared/...."/>
> >         </url>
> >     </resolvers>
> >
> > The user then defines their username and password locally, note that
> > we are using Artifactory which requires the "Artifactory Realm"
> > setting.  This setup works fine for us.
> >
> > Regards
> > Jonathan Oulds
> >
> >
> > -----Original Message-----
> > From: Rodrigue ... [mailto:rlagoue@googlemail.com]
> > Sent: 08 August 2013 11:04
> > To: ivy-user@ant.apache.org
> > Subject: Re: the credentials tag in ivysettings.xml
> >
> > The consequence of this issue, is that i'm not able to move the SR2 of
> > eclipse juno.
> >
> >
> > On Thu, Aug 8, 2013 at 12:03 PM, Rodrigue ... <rlagoue@googlemail.com
> > >wrote:
> >
> > > Just another try, may be something else is facing the same issue.
> > >
> > > I'm facing an issue here concerning the credentials tag supposed to
> > > be supported by the ivysettings xml specification (
> > > http://ant.apache.org/ivy/history/latest-milestone/settings/credenti
> > > al
> > > s.html
> > > )
> > >
> > > Since my repository is protected using a http-authentication, I
> > > would like to use the credentials tag to parameterize the username
> > > and passwd
> > values.
> > > I just tried by entering the values (username and passwd) directly
> > > without success.
> > >
> > > I have the feeling that this credentials tag is not considered
> > > during the resolve of the dependencies, am I wrong?
> > >
> > > Thank you for any help
> > >
> > > BR
> > >
> > >
> > > On Sat, Jun 29, 2013 at 7:21 PM, Rodrigue ...
> > ><rlagoue@googlemail.com
> > >wrote:
> > >
> > >> Hi everybody,
> > >>
> > >> I'm facing an issue here concerning the credentials tag supposed to
> > >> be supported by the ivysettings xml specification (
> > >> http://ant.apache.org/ivy/history/latest-milestone/settings/credent
> > >> ia
> > >> ls.html
> > >> )
> > >>
> > >> Since my repository is protected using a http-authentication, I
> > >> would like to use the credentials tag to parameterize the username
> > >> and passwd values. I just tried by entering the values (username
> > >> and
> > >> passwd) directly without success.
> > >>
> > >> I have the feeling that this credentials tag is not considered
> > >> during the resolve of the dependencies, am I wrong?
> > >>
> > >> Thank you for any help
> > >>
> > >> BR
> > >> Rodrigue
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message