ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Cross <...@goots.org>
Subject Re: Dependency Resolution
Date Thu, 14 Jun 2012 19:31:04 GMT
Hi,

False alarm - in my ivysettings.xml I had

   <resolvers>
         <chain name="default" returnFirst="true">
            <url name="foobar" m2compatible="true" force="true" 
alwaysCheckExactRevision="true">
....


And according to 
http://ant.apache.org/ivy/history/latest-milestone/settings/resolvers.html 
the force was making it use latest.integration. Removing that meant it 
used the version I asked for.

Cheers

Nick


On 14/06/12 08:35, Nick Cross wrote:
>
>
> Hi,
>
> I have this ivy in my Ant build file:
>
> <ivy:resolve showprogress="false" transitive="false" haltonfailure="false">
> <dependency org="${builder-package}" name="${builder-name}"
> rev="${builder-version}"
> changing="true" force="true">
> <artifact name="${builder-name}" ext="zip"/>
> </dependency>
> </ivy:resolve>
>
>
> Where builder-version is e.g. '5.2'. However when I run it I is
> resolving version 5.3 rather than 5.2 in the repository.
>
> How can I force it to download *just* the version I specify?
>
> Cheers
>
> Nick
>


Mime
View raw message