ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Hurne <m...@thehurnes.com>
Subject Re: windows vs linux paths in properties
Date Tue, 27 Mar 2012 19:11:33 GMT
On Tue, Mar 27, 2012 at 2:52 PM, Matt Hurne <matt@thehurnes.com> wrote:
> On Tue, Mar 27, 2012 at 2:27 PM, James Moore <james@restphone.com> wrote:
>> On Tue, Mar 27, 2012 at 7:27 AM, Jasper Floor <jasper.floor@m4n.nl> wrote:
>>
>>> This fails terribly in windows because of the /
>>> The reason, obviously is that the / should be a \ in windows.\
>>>
>>
>> That shouldn't be the problem; both \ and / are file separators in Windows
>> and always have been.  There are some Windows tools that use / as something
>> other than a file separator (like cmd), but that's a specific issue for
>> that specific tool.
>
> Jasper, can you be more specific about what behavior you see when
> using forward slashes (/)?  Like the others, I double-checked and can
> confirm that we are using forward slashes in <property> elements in
> our ivysettings.xml on Windows without issue.  Notice the difference
> though: you said you are having issues with the <properties> element,
> not the <property> element that we are using them in without issue.
> We are not currently using the <properties> element, but maybe I'll
> try it when I get a chance.

I did test out a <properties> element in my ivysettings.xml on Windows
(XP) with forward slashes as file separators and I did not see any
issues.

Mime
View raw message