ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: IvyDE won't resolve resource dependencies at runtime?
Date Fri, 14 Oct 2011 08:11:29 GMT

Le 7 oct. 2011 à 11:39, Peter De Maeyer a écrit :

> Hi,
> 
> Whenever I run a unit test from Eclipse which depends on a resource of another dependency,
I get an exception that the resource cannot be found.
> 
> It seems that IvyDE version 2.1.0.201008101807-RELEASE won't resolve resource dependencies
at runtime. It works in version 2.0.0.final-200907011148-RELEASE.
> 
> I'd like to understand what is wrong. Am I missing something or is this a bug?

Probably a bug.
The resolve of the dependencies at runtime was not totally under control, I had a lot of difficulties
to understand the Eclipse APIs about launching. I think I got it now and it will be better
with the 2.2.

With all the risks that it brings, you can try a snapshot build of IvyDE:
http://ant.apache.org/ivy/ivyde/download.cgi#hudson

Nicolas


Mime
View raw message