ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Haynes <david.dhc...@gmail.com>
Subject Re: Publishing POM to Artifactory not working
Date Fri, 23 Sep 2011 13:04:45 GMT
Thanks. That was the issue. On to the next problem!

On Thu, Sep 22, 2011 at 5:03 PM, Rod MacKenzie <rod.n.mackenzie@gmail.com>wrote:

> Do you have an entry in the publications section of the ivy file for
> the pom file?
>
> Here's the publications section from an ivy file I've been using to
> publish to a Nexus repository
> <publications>
>        <artifact type="jar" ext="jar"/>
>        <artifact type="source" ext="jar" m:classifier="sources"/>
>        <artifact type="javadoc" ext="jar" m:classifier="javadoc"/>
>        <artifact type="descriptor" ext="pom"/>
> </publications>
>
> I think the artifacts pattern in the publish task is used only to find
> the artifacts and isn't used to determine what to publish. Hope this
> helps.
>
> Rod
>
> On 22 September 2011 18:27, David Haynes <david.dhcinc@gmail.com> wrote:
> > Hey there.
> > I am having a bit of a problem publishing a pom file to my Artifactory
> > repository using the Ant tools.
> > The ant target does not seem to be finding the pom file to publish.
> >
> > Here is a piece from the build.xml file:
> >        <ivy:makepom ivyfile="ivy.xml"
> > pomfile="${dist.dir}/${name}-${version}.pom" conf="default, runtime">
> >            <mapping conf="default" scope="compile"/>
> >            <mapping conf="runtime" scope="runtime"/>
> >        </ivy:makepom>
> >
> >        <ivy:publish organisation="${org}" module="${name}"
> > revision="${version}-SNAPSHOT"
> >            resolver="libs-snapshot-local" srcivypattern="ivy.xml"
> > update="true" overwrite="true" publishivy="false">
> >            <artifacts pattern="${dist.dir}/[artifact]-${version}.[ext]"/>
> >            <artifacts pattern="${dist.dir}/[artifact]-${version}.pom"/>
> >        </ivy:publish>
> >
> > My resolver looks like this:
> > <url name="libs-snapshot-local" m2compatible="true">
> >     <artifact pattern="
> >
> http://192.168.215.245:8081/artifactory/libs-snapshot-local/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]
> "
> > /
> >      <ivy pattern="
> >
> http://192.168.215.245:8081/artifactory/libs-snapshot-local/[organisation]/[module]/[revision]/ivy-[revision].xml
> "
> > />
> >  </url>
> >
> > When I run the build, I get the following:
> > [ivy:publish] :: publishing :: com.cinbell.cbts#rest-lib
> > [ivy:publish]   published rest-lib to
> >
> http://192.168.215.245:8081/artifactory/libs-snapshot-local/com/cinbell/cbts/rest-lib/1.0.0-SNAPSHOT/rest-lib-1.0.0-SNAPSHOT.jar
> >
> > And that is what shows up in the Artifactory repository.
> >
> > Notice that there is no attempt to publish the pom file....
> >
> > The pom file is generated and is in the ${dist.dir} directory as
> > [artifact]-${version}.pom.
> >
> > I am using ivy version 2.2.0.
> >
> > If anyone has any suggestions, I would love to hear them. I am out of
> ideas
> > on this one.
> >
> > Thanks
> > -david-
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message