ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zharvey <zachary.har...@gmail.com>
Subject Can't get Ivy to see modules
Date Fri, 09 Sep 2011 19:11:40 GMT

I have been racking my brains trying to figure out what is happening here.

In my ivysettings.xml file, I specify the following resolver:

            <filesystem name="local">  
              <ivy
pattern="${ivy.settings.dir}/artifacts/[organisation]/[module]/  
               [artifact]-[revision]-ivy.xml" />  
              <artifact
pattern="${ivy.settings.dir}/artifacts/[organisation]/[module]/  
              [artifact]-[revision].[ext]" />

So, for instance, I use the Apache Commons CLI jar a lot to handle
command-line arguments. I have this jar stored under:

MyIvyRoot/artifacts/apache/commons-cli/

And the two files I have in that directory are: (1) commons-cli-1.2.jar and
(2) commons-cli-1.2-ivy.xml.

When I run resolve I get the following output, and ultimately an error:

[ivy:resolve] module not found: apache#commons-cli;1.2
[ivy:resolve] ==== local: tried
[ivy:resolve] MyIvyRoot/artifacts/commons-cli/commons-cli-1.2-ivy.xml
[ivy:resolve] -- artifact apache#commons-cli;1.2!commons-cli.jar:
[ivy:resolve] MyIvyRoot/artifacts/commons-cli/commons-cli-1.2.jar

I have checked, and re-checked, and re-re-checked the URIs, and for the life
of me, can't understand how Ivy can't see both my jar and my XML descriptor.

Does anybody have any ideas as to what this could be?!? Any help on this is
appreciated enormously.
-- 
View this message in context: http://old.nabble.com/Can%27t-get-Ivy-to-see-modules-tp32434081p32434081.html
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message