ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Brown <tpbr...@gmail.com>
Subject Re: Question about excludes
Date Wed, 27 Jul 2011 14:28:24 GMT
I think you can use Override to force the transitive dependency to the
higher version.

http://ant.apache.org/ivy/history/2.0.0/ivyfile/override.html

~Sent from my mobile device. Please pardon any oddities :-)

On Jul 27, 2011, at 4:18 AM, David Sills <DSills@datasourceinc.com> wrote:

> All:
>
> I have a project that has a dependency on slf4j. I'm generally using
> 1.6.1 (with my own patch to fix a bug), but one of my dependencies has a
> transitive dependency on 1.5.6. I cannot figure out how to get rid of
> this JAR file in the ivyIDE container. I am trying this:
>
> <exclude org="org.slf4j" module="com.springsource.slf4j.api"
> artifact="com.springsource.slf4j.api-1.5.6.jar" matcher="exact"/>
>
> The org and module correspond exactly to how the offending JAR file is
> stored in my repository. I know I have to be missing something, but I
> simply can't see it. Does anyone?
>
> I have tried:
>
> <exclude org="org.slf4j" module="com.springsource.slf4j.api"/>
>
> But of course that removes all versions of the JAR file, even the one I
> want to keep. Can someone explain why there is not a "rev" attribute in
> the exclude element? It would seem logical - don't take this revision of
> the library.
>
> Thanks!
>
> David Sills
>

Mime
View raw message