ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Louis Boudart <jeanlouis.boud...@gmail.com>
Subject Re: Unable to fetch a library from my repo
Date Fri, 24 Jun 2011 13:02:10 GMT
Hi again,

I'm not sure to have enough information, but it seems you're using a wrong
pattern for dynamic revision (see
http://ant.apache.org/ivy/history/latest-milestone/ivyfile/dependency.html).
I assume you used "[3.3.0,4.0.0)", instead of :

   - "[3.3.0,4.0.0]" (a version  greater or equal to 3.3.0 and lower or
   equal to 4.0.0)
   - "[3.3.0,4.0.0[" (a version  greater or equal to 3.3.0 and lower than
   4.0.0)

Hope that helps,

2011/6/24 jerome moliere <jerome.moliere@gmail.com>

> Hi all,
> this is my first message here....
> I am about delivering a continuus integration solution to my
> customers, it's built upon Hudson, ANT + Ivy , artifactory ,bnd and
> Test-NG
> I work on a project based on OSGi , this is a multi - multi projects
> one  with an organisation like this:
> P1 :
> module 11
> module 12
> module 13
>
> P2:
> module21
> module22
>
> P3:
> module31
> module32
> module33
>
> The whole project is about 300 OSGi bundles
> I am already able to build about 250 bundles, but in one module three
> 's a dependency that Ivy can't find I've got a message like this:
> [ivy:resolve] :: resolution report :: resolve 8479ms :: artifacts dl 1ms
>
>  ---------------------------------------------------------------------
>        |                  |            modules            ||   artifacts
> |
>        |       conf       | number| search|dwnlded|evicted||
> number|dwnlded|
>
>  ---------------------------------------------------------------------
>        |        std       |   5   |   2   |   0   |   0   ||   4   |   0
> |
>        |       test       |   0   |   0   |   0   |   0   ||   0   |   0
> |
>
>  ---------------------------------------------------------------------
> [ivy:resolve]
> [ivy:resolve] :: problems summary ::
> [ivy:resolve] :::: WARNINGS
> [ivy:resolve]           module not found:
> org.eclipse.core#commands;[3.3.0,4.0.0)
> [ivy:resolve]   ==== public: tried
> [ivy:resolve]
>
> http://localhost:8081/artifactory/repo/org/eclipse/core/commands/[revision]/commands-[revision].pom
> [ivy:resolve]     [3.3.0-I20070605-0010, 3.2.0-I20060605-1400]
> [ivy:resolve]     -- artifact
> org.eclipse.core#commands;[3.3.0,4.0.0)!commands.jar:
> [ivy:resolve]
>
> http://localhost:8081/artifactory/repo/org/eclipse/core/commands/[revision]/commands-[revision].jar
> [ivy:resolve]     [3.3.0-I20070605-0010, 3.2.0-I20060605-1400]
> [ivy:resolve]   ==== artifactory-publish: tried
> [ivy:resolve]
>
> http://localhost:8081/artifactory/libs-release-local/org.eclipse.core/commands/[revision]/ivy-[revision].xml
> [ivy:resolve]     -- artifact
> org.eclipse.core#commands;[3.3.0,4.0.0)!commands.jar:
> [ivy:resolve]
>
> http://localhost:8081/artifactory/libs-release-local/org.eclipse.core/commands/[revision]/commands-[revision].jar
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]           :: org.eclipse.core#commands;[3.3.0,4.0.0): not
> found
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>
>
> As stated the repository contains one version of
> org.eclipse.core.commands with a strange version number (it's not my
> fault -) )
> The dependency requires any version between 3.3 and 4.0.0 but the
> version living in the repo does not match ...
>
> what can I do ? Should I use a Latest-Startegy ? if yes, how ?
> Can I implement my own strategy ? Can i force Ivy to use the version
> in the repository ?
>
>
> Thanks for your help
> Kind regards
> jerome
>
> J.MOLIERE - Mentor/J
> auteur Eyrolles
>



-- 
Jean Louis Boudart
Independent consultant
Project Lead http://www.easyant.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message