ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Derek E <snekse.li...@gmail.com>
Subject Re: retrieve sync not deleting even when it says it is
Date Thu, 10 Mar 2011 15:42:04 GMT
Okay, following up on this.  I've reviewed the documentation found here:
http://ant.apache.org/ivy/ivyde/history/latest-milestone/index.html

<http://ant.apache.org/ivy/ivyde/history/latest-milestone/index.html>And it
looks like I have everything setup as recommended.  So what doesn't make
sense to me is why is there a lock on the jars after I remove them from
Ivy.xml?  My thinking is that once I remove that dependency, then IvyDE will
do a resolve and remove that file from the classpath, thus releasing any
locks.  Then when I call the ivy:retrieve ant task with sync="true", it
should be free to delete that file.  Am I missing something?  How do most
people have this setup?


On Wed, Mar 9, 2011 at 5:49 PM, Derek E <snekse.lists@gmail.com> wrote:

> Good call.  I have to shut down Eclipse to delete the files.  I have IvyDE
> installed, but followed the setup described here to handle the classpath.
>
>
> http://www.beilers.com/2010/07/eclipse-3-6-helios-wtp-ivy-and-deployment-assembly-working-reliably-at-last/
>
>
> On Wed, Mar 9, 2011 at 1:50 PM, Maarten Coene <maarten_coene@yahoo.com>wrote:
>
>> Maybe they are locked by another process?
>> Can you delete them  with Windows Explorer?
>>
>> Maarten
>>
>>
>>
>>
>> ----- Original Message ----
>> From: Derek E <snekse.lists@gmail.com>
>> To: ivy-user@ant.apache.org
>> Sent: Wed, March 9, 2011 7:40:31 PM
>> Subject: retrieve sync not deleting even when it says it is
>>
>> I have the following build target:
>>
>> ***   build.xml   ***
>>    <target name="ivy-retrieve-dist" ">
>>     <ivy:retrieve pattern="${war.lib}/${ivy.retrieve.pattern}" conf="dist"
>> sync="true" />
>>    </target>
>>
>> Which, when run with the -debug flag, returns the following in the
>> console:
>> *** Debug Logs   ***
>> [ivy:retrieve] syncing...
>> [ivy:retrieve] deleting
>>
>> C:\dev\Workspace\COR-1568\WebContent\WEB-INF\lib\spring-web-2.5.6.SEC01.jar
>> [ivy:retrieve] deleting
>> C:\dev\Workspace\COR-1568\WebContent\WEB-INF\lib\spring-support-1.2.9.jar
>> [ivy:retrieve] deleting
>> C:\dev\Workspace\COR-1568\WebContent\WEB-INF\lib\spring-dao-1.2.9.jar
>> [ivy:retrieve] deleting
>> C:\dev\Workspace\COR-1568\WebContent\WEB-INF\lib\activation-1.1.jar
>> [ivy:retrieve] deleting
>> C:\dev\Workspace\COR-1568\WebContent\WEB-INF\lib\spring-aop-1.2.9.jar
>> [ivy:retrieve] 122 artifacts copied (63841kB/458ms)
>> [ivy:retrieve] retrieve done (458ms)
>> Setting project property: ivy.nb.targets.copied -> 122
>> Setting project property: ivy.targets.copied -> true
>> BUILD SUCCESSFUL
>> Total time: 4 seconds
>>
>> But when I check C:\dev\Workspace\COR-1568\WebContent\WEB-INF\lib\, those
>> jar files that were indicated as being deleted are still in there.  What
>> can
>> I do to find out why these files aren't getting deleted?
>>
>> Thanks
>>
>>
>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message