ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: Re: Error parsing ivy.xml files using Jenkins
Date Fri, 25 Feb 2011 07:39:16 GMT

The Jenkins Ivy plugin uses Ivy 2.1 internally so yes, it would not allow  
version="2.2". Ivy 2.1 only allows "1.0", "1.1", "1.2", "1.3", "1.4"  
and "2.0".


On Feb 25, 2011 12:59am, David Goblirsch  
<> wrote:
> David Goblirsch wrote:

> Kent Rosenkoetter wrote:

> I have not been able to find any ivy.xml file in the wild that works with  
> Jenkins+Ivy. In fact, I just created a new empty project and put the  
> following minimal ivy.xml file into it, and still got the same  
> NullPointerException.

> xsi:noNamespaceSchemaLocation="">

> If that fails, I don't know how anybody is using this successfully.

> BTW, the reference manual says this about the "version" attribute of :

> the version of the ivy file specification - should be '2.0' with current  
> version of ivy

> but after seeing your email I tried 2.2 and it works, but 2.3 does not.  
> So something in the code allows 2.2,

> even though the manual says to stick with 2.0. I also observe that the  
> schema file ivy.xsd doesn't constrain its value

> other then to say it is an xs:string.

> I was wrong when I said it worked with version="2.2". Ant with ivy from  
> the command line works with ivy-module version="2.2".

> When I tried it on the Jenkins server, the individual project built fine  
> also. But then the Jenkins log filled with module descriptor

> errors! Apparently the plugin then goes to parse the ivy.xml itself as  
> part of finding the upstream and downstream

> dependencies. I guess the plugin's parser takes the Ivy ref manual at its  
> word, that the ivy-module version should be 2.0.

> So change your version to 2.0 like the ref manual says it should be, and  
> see if that works. It works for me.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message