ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: trunk build IvyDE refuses to install on RAD 7.5
Date Fri, 17 Dec 2010 13:50:44 GMT

Le 16 déc. 2010 à 17:15, Clements Mark a écrit :

> Hi,
> 
> When trying to install the latest trunk build of IvyDE on Rad 7.5.5.1, I get the error
> 
> Apache IvyDE is already installed, so an update will be performed instead.
> Unsatisfied dependency: [org.apache.ivyde.feature.feature.group 2.2.0.201012140258-hudson-166]
requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.4.0,4.0.0)
> Unsatisfied dependency: [org.apache.ivyde.feature.feature.group 2.2.0.201012140258-hudson-166]
requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.console/[3.4.0,4.0.0)
> Unsatisfied dependency: [org.apache.ivyde.feature.feature.group 2.2.0.201012140258-hudson-166]
requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help/[3.4.0,4.0.0)
> Unsatisfied dependency: [org.apache.ivyde.feature.feature.group 2.2.0.201012140258-hudson-166]
requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help/[3.4.0,4.0.0)
> Unsatisfied dependency: [org.apache.ivyde.feature.feature.group 2.2.0.201012140258-hudson-166]
requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.4.0,4.0.0)
> Unsatisfied dependency: [org.apache.ivyde.feature.feature.group 2.2.0.201012140258-hudson-166]
requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.console/[3.4.0,4.0.0)
> 
> And cannot proceed. I can install Ivy (2.2.0.final_20101215005611) but not IvyDE (2.2.0.201012140258-hudson-166).
This has been the case for the last few trunk revisions of IvyDE. Currently I have installed
(and functioning correctly)
> 
> Ivy - 2.2.x-local-20101129100128
> IvyDE - 2.1.0.201008101807-RELEASE installed
> 
> Is there any chance of getting this working again for RAD 7.5? (I know version 8.0 is
available, but we aren't actively looking at it yet)

As stated in the last release announcement of IvyDE, IvyDE 2.1 is the last release which will
be compatible with Eclipse 3.2 and 3.3. For the next version, IvyDE will require at least
Eclipse 3.4 because we would like to add a new feature [1] which requires it.

It may be technically possible to keep it compatible with 3.3. Eclipse 3.3 users would then
not being able to view the new features. But we would like to keep it simple and keep moving
forward.
But we are not closed for discussion for still keeping some backward compatibility if it affects
too much users.

Nicolas

[1] https://issues.apache.org/jira/browse/IVYDE-208


Mime
View raw message