ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From samyem <sam...@gmail.com>
Subject Ivy with Nexus
Date Fri, 10 Dec 2010 15:17:48 GMT

I am trying to use Ivy/IvyIde with Nexus. This is the simple configuration I
got: 

<ivysettings>
	<resolvers>
		<url name="nexus" m2compatible="true">  
			<artifact			
pattern="http://mynexus/nexus/content/repositories/maven1_public/[organisation]/[module]/[revision]/[artifact]-[revision](-[classifier]).[ext]"
			  
			/> 
		</url> 
	</resolvers>	
	<settings defaultResolver="nexus"/>
</ivysettings>

And my ivy.xml file looks like this right now:

<ivy-module version="2.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      
xsi:noNamespaceSchemaLocation="http://ant.apache.org/ivy/schemas/ivy.xsd" >
    <info
        organisation="org"
        module="Controller"
        status="integration">
	</info>
	
	<dependencies>
		<dependency org="commons-lang" name="commons-lang" rev="2.1" />
		<dependency org="org.apache.commons" name="commons-email" rev="1.2"/>
		<dependency org="org.apache.activemq"  name="activemq-all" rev="5.3.1"/>		
	</dependencies>	
</ivy-module>

Now all is well and my jars are getting pulled from nexus as expected and I
got eclipse to pick up the classpath. However, when I use nexus I do not get
the sources pulled from nexus to my local cache and Eclipse is unable to
attach the sources for the jars. When I use the default settings that pulls
from ibiblio.org, the source does get downloaded to local cache and Eclipse
is able to pick up the sources. So how can I make it download the sources
with Nexus?

Thank you,
Samyem

-- 
View this message in context: http://old.nabble.com/Ivy-with-Nexus-tp30427010p30427010.html
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message