ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean (Contractor)" <dean.hil...@broadridge.com>
Subject RE: publish failing(more info)
Date Fri, 26 Nov 2010 16:54:36 GMT
Okay, so I found out I should tweak my ivysettings file from googling
your artifactory-publish, but I still
get a similar failure(google is not showing anyone getting these same
failures but could it be I am using 2.3.1 version of artifactory and not
many are using that yet...what versions are people on that are stable?)

or com.broadridge#hibernate;working@DNVR-DHILLER: java.io.IOException:
PUT opera
tion to URL
http://206.88.41.159:8081/artifactory/libs-snapshots-local/com.broad
ridge/hibernate/1.0/ivy-1.0.xml failed with status code 405: HTTP method
PUT is
not supported by this URL

any ideas on this?

My ivysettings file now looks like so...

<?xml version="1.0" encoding="UTF-8"?>
<ivy-settings>
  <settings defaultResolver="main" />
  <!--Authentication required for publishing (deployment). 'Artifactory
Realm' is the realm used by Artifactory so don't change it.-->
  <CREDENTIALS HOST="artHost" REALM="Artifactory Realm" USERNAME="admin"
PASSWD="password" />
  <resolvers>
    <chain name="main">
      <ibiblio name="broadridge" m2compatible="true"
root="http://artHost:8081/artifactory/libs-release" />           
    </chain>
    <url name="artifactory-publish">
        <!-- You can use  m2compatible="true" instead of specifying your
own pattern -->
        <artifact pattern=
 
"http://artHost:8081/artifactory/libs-snapshots-local/[organization]/[mo
dule]/[revision]/[artifact]-[revision].[ext]"/>
        <ivy
pattern="http://artHost:8081/artifactory/libs-snapshots-local/[organizat
ion]/[module]/[revision]/ivy-[revision].xml" />
    </url>    
  </resolvers>
</ivy-settings>


-----Original Message-----
From: Maarten Coene [mailto:maarten_coene@yahoo.com] 
Sent: Thursday, November 25, 2010 2:18 AM
To: ivy-user@ant.apache.org
Subject: Re: publish failing(more info)

You should use resolver "artifactory-publish" to publish your modules:
<ivy:publish resolver="artifactory-publish"  pubrevision="1.0"/>

regards,
Maarten




----- Original Message ----
From: "Hiller, Dean (Contractor)" <dean.hiller@broadridge.com>
To: ivy-user@ant.apache.org
Sent: Thu, November 25, 2010 1:35:24 AM
Subject: RE: publish failing(more info)

Oh, almost forgot.  My resolver in ivysettings.xml.  I tried the default
artifactory generated one which just has the ibiblio one with my
artifactory ip and then tried this one too...(and changed publish
resolver to artifactory-publish) but neither worked.  Any ideas?



  <settings defaultResolver="main" />

  <!--Authentication required for publishing (deployment). 'Artifactory
Realm' is the realm used by Artifactory so don't change it.-->

  <CREDENTIALS HOST="xxxx" REALM="Artifactory Realm" USERNAME="admin"
PASSWD="password" />

  <resolvers>

    <chain name="main">

      <ibiblio name="xxxx" m2compatible="true"
root="http://xxxx:8081/artifactory/libs-release" />

        <url name="artifactory-publish">

        <!-- You can use  m2compatible="true" instead of specifying your
own pattern -->

        <artifact
pattern="http://xxxx:8081/artifactory/libs-release-local/[organization]/
[module]/[revision]/[artifact]-[revision].[ext]"/>

        <ivy
pattern="http://http://xxxx:8081/artifactory/libs-release-local/[organiz
ation]/[module]/[revision]/ivy-[revision].xml" />

    </url>

      

    </chain>

  </resolvers>





From: Hiller, Dean (Contractor) 
Sent: Wednesday, November 24, 2010 5:03 PM
To: 'ivy-user@ant.apache.org'
Subject: publish failing



I keep getting this on publish.....



[ivy:publish] :: publishing :: com.xxxxxx#hibernate



BUILD FAILED

C:\AAROOT\area1\modules\bldfiles\build.xml:56: impossible to publish
artifacts f

or com.xxxxxxx#hibernate;working@HILLER: java.io.IOException: PUT opera

tion to URL
http://555.55.55.555:8081/artifactory/libs-release/com/xxxxxx/to

ols/1.0/ivy-1.0.xml failed with status code 405: Method Not Allowed



Here is my ant code



            <ivy:resolve file="hibernate.xml"/>

            <ivy:publish resolver="main"  pubrevision="1.0"/>



Any way to fix this?  (I am using artifactory and not sure how I would
put a url in artifactory to test this failure).

Do I have to have http-client?  I don't think the sample I copied
downloads that..it only downloads ivy jar and

that is it I think.

Thanks,

Dean


This message and any attachments are intended only for the use of the
addressee 
and
may contain information that is privileged and confidential. If the
reader of 
the 

message is not the intended recipient or an authorized representative of
the
intended recipient, you are hereby notified that any dissemination of
this
communication is strictly prohibited. If you have received this
communication in
error, please notify us immediately by e-mail and delete the message and
any
attachments from your system.



      
This message and any attachments are intended only for the use of the addressee and
may contain information that is privileged and confidential. If the reader of the 
message is not the intended recipient or an authorized representative of the
intended recipient, you are hereby notified that any dissemination of this
communication is strictly prohibited. If you have received this communication in
error, please notify us immediately by e-mail and delete the message and any
attachments from your system.


Mime
View raw message