ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject Re: Credentials not applied for one ant project.
Date Wed, 29 Sep 2010 19:08:08 GMT
Could you try again with latest trunk build in debug mode (running Ant with the 
-d option) and check the output?
Perhaps you can find some more detail about what's going wrong?

If you don't find anyhting in that log, you can send it to me and I'll take a 
look as well.

You can find the latest trunk builds here: 
https://hudson.apache.org/hudson/view/Ant/job/Ivy/

Maarten



----- Original Message ----
From: Дмитрий Букеев <dbuk@sprut.ru>
To: ivy-user@ant.apache.org
Sent: Wed, September 29, 2010 12:21:29 PM
Subject: Re: Credentials not applied for one ant project.

Hello Maarten.
I face this trouble with apache-ivy-2.1.0 and try apache-ivy-2.2.0-rc1
also .
But release candidate not help me :(

29.09.2010 13:16, Maarten Coene пишет:
> Which Ivy version do you use?
> Ivy 2.2.0-RC1 contains some bugfixes regarding authentication problems in 
> combination with commons-httpclient.
>
> Maarten
>
>
> ----- Original Message ----
> From: Дмитрий Букеев <dbuk@sprut.ru>
> To: ivy-user@ant.apache.org
> Sent: Wed, September 29, 2010 10:52:16 AM
> Subject: Credentials not applied for one ant project.
>
> Hi all.
>
> I use Ivy with Ant and Hudson more  one year. There are about 3 Hudson's
> ant project which publish artifacts with Ivy ant task at my Hudson server.
> Also I use Artifactory as repository.
> Last week I update Artifactory from version 2.1.2 upto 2.2.5.
> After this update one project can't publish it artifact to its repository.
>
> As I have really complex ant project I make little ant task for publish
> testing purpose.
>          <target name="dR" >
>             <delete file="./SprutCam_NSIS/ivy.xml"/>
>             <ivy:settings file="${env.secret}/ivysettings.xml" />
>             <ivy:resolve  showprogress="true" />
>             <ivy:publish resolver="SprutTechArtifactory"
>                 pubrevision="7.1.1.1"
>                 status="milestone"
>                 update="true"
>                 overwrite="true"
>                 conf="dist,dealers,map"
>                 >
>                     <artifacts pattern="./SprutCam_NSIS/[artifact].[ext]" />
>             </ivy:publish>
>         </target>
>
> File ivysettings.xml is copy of "good" project's file.
> It is this file
> <?xml version="1.0" encoding="utf-8"?>
> <ivysettings>
>    <settings  defaultResolver="SprutTechArtifactory"/>
>    <credentials host="artifactory.office.sprut.ru"
>                 realm="Artifactory Realm"
>                 username="*****"
>                 passwd="******" />            
>    <resolvers>
>        <url name="SprutTechArtifactory" m2compatible="true"
> checksums="md5,sha1">
>               <artifact
>pattern="http://artifactory.office.sprut.ru:8081/artifactory/SprutTechRepo/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]"/>
>>
>
>               <ivy
>pattern="http://artifactory.office.sprut.ru:8081/artifactory/SprutTechRepo/[organisation]/[module]/[revision]/ivy-[revision].xml"
>"
>
> />            
>        </url>
>        <url name="SprutNightBuildsArtifactory" m2compatible="true"
> checksums="md5,sha1">
>               <artifact
>pattern="http://artifactory.office.sprut.ru:8081/artifactory/SprutNightBuilds/[organisation]/[module]/[revision]/[artifact]-[revision]-SNAPSHOT.[ext]"/>
>>
>
>               <ivy
>pattern="http://artifactory.office.sprut.ru:8081/artifactory/SprutNightBuilds/[organisation]/[module]/[revision]/ivy-[revision]-SNAPSHOT.xml"
>"
>
> />            
>        </url>
>    </resolvers>
> </ivysettings>
>
> When I run  this task  I get next message
> .
> .
> .
> .
> [ivy:resolve] credentials added: Artifactory
> Realm@artifactory.office.sprut.ru builder/*******
> .
> .
> .
> 28.09.2010 10:34:09 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: I/O exception (java.net.SocketException) caught when processing
> request: Software caused connection abort: socket write error
> 28.09.2010 10:34:09 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: Retrying request
> 28.09.2010 10:34:39 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: I/O exception (java.net.SocketException) caught when processing
> request: Software caused connection abort: socket write error
> 28.09.2010 10:34:39 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: Retrying request
> 28.09.2010 10:35:09 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: I/O exception (java.net.SocketException) caught when processing
> request: Software caused connection abort: socket write error
> 28.09.2010 10:35:09 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: Retrying request
>
> And it is artifactory log for it :
> 2010-09-28 10:34:09,740 [DENIED DEPLOY]
> SprutTechRepo:ru/sprut/sprutcam/installator/7.1.1.1/sprutcam-7.1.1.1.exe
> for anonymous/192.168.64.1.
> 2010-09-28 10:34:39,802 [DENIED DEPLOY]
> SprutTechRepo:ru/sprut/sprutcam/installator/7.1.1.1/sprutcam-7.1.1.1.exe
> for anonymous/192.168.64.1.
> 2010-09-28 10:35:09,879 [DENIED DEPLOY]
> SprutTechRepo:ru/sprut/sprutcam/installator/7.1.1.1/sprutcam-7.1.1.1.exe
> for anonymous/192.168.64.1.
>
> It is very strange for me as other project with same credentials have
> success publish to this repository and this publish was success for old
> version Artifactory .
>
> I try modify this task and change commons-http-client library version
> but I have empty result today :(
>
> Have you any idea what can I do ?
>
> With best regards
>
> Dmitry.
>
>
>      
>
>
>  


      

Mime
View raw message