ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Aston <Timothy.As...@ca.ibm.com>
Subject Re: [ANNOUNCE] Apache IvyDE 2.1.0 released
Date Fri, 20 Aug 2010 14:50:35 GMT

Its great to see a new version. :)  Unfortunately, I seem to be having some
troubles getting it to find my ivysettings.xml file.

With IvyDE 2.0. I used to have "project://ce_main/build/ivysettings.xml" as
my Ivy settings path, which worked just fine.  After upgrading to 2.1, I
started getting errors.  So I've tried using the "Workspace" and "File
System" buttons to select the actual file, but I'm still getting errors:

org.apache.ivyde.eclipse.IvyDEException: Error while resolving the ivy
instance for build/ivy.xml in 'ce_sdk':
  The Ivy settings file
'file:/C:/Documents%20and%20Settings/astont/workspace-head2/ce_main/build/ivysettings.xml'
 cannot be found

      at
org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerState.getIvy
(IvyClasspathContainerState.java:216)

      at
org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerState.doGetIvy
(IvyClasspathContainerState.java:185)

      at
org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerState.getIvy
(IvyClasspathContainerState.java:136)

      at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.run
(IvyResolveJob.java:69)

      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

The file most certainly does exist, and like I said, it was get loaded with
IvyDE 2.0 perfectly fine..

Any suggestions on how to fix this?


-Tim



From:       Nicolas Lalevée <hibou@apache.org>?
To:         announce@apache.org, Ant Developers List <dev@ant.apache.org>,
            ivy-user@ant.apache.org
Date:       08/19/2010 10:53 AM,
Subject:    [ANNOUNCE] Apache IvyDE 2.1.0 released



August 19, 2009 - The Apache IvyDE project is pleased to announce its 2.1.0
release.

IvyDE is the plugin which integrates Ivy into Eclipse. It lets you manage
your dependencies declared in an ivy.xml in your Java Eclipse projects.
IvyDE will contribute to the classpath of your Java project or you can make
it retrieve your dependencies directly into your project. Last but not
least IvyDE offer editors of ivy.xml and ivysettings.xml files with
completion. Get some preview here:
http://ant.apache.org/ivy/ivyde/screenshots.html

Major changes in this release:
* the integration within the Eclipse Java launchers has been greatly
improved,
* support for Eclipse variables in most IvyDE settings,
* a context menu is now available at the project level so it is now
possible to resolve many selected projects

Compatibility:
* this release is expected to work with every version of Ivy 2.1 or
superior
* this will be the last release which will be compatible with Eclipse 3.2
and 3.3, and it has been successfully tested up to Eclipse 3.6


We encourage all users of IvyDE to update to this new version.


A more detailed release notes can be read there:
http://ant.apache.org/ivy/ivyde/history/latest-milestone/release-notes.html

Issues should be reported to:
https://issues.apache.org/jira/browse/IVYDE

Download the 2.1.0 release at:
http://ant.apache.org/ivy/ivyde/download.cgi

Or use directly the Eclipse updatesite:
http://www.apache.org/dist/ant/ivyde/updatesite

More information can be found on the IvyDE website:
http://ant.apache.org/ivy/ivyde/

Regards,
Nicolas Lalevée


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message