ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Clitheroe <g.clithe...@gmail.com>
Subject Re: Reference build-path not found.
Date Mon, 23 Aug 2010 19:35:46 GMT
You can pass -d to ant.

Do you need ${} round dist.dir?

-G

On 24 Aug 2010 07:29, "Ben Cuthbert" <ben_cuthbert@yahoo.co.uk> wrote:
> Apologies I think I solved this, well sort of. Now when the publish-remote
gets called I get the following error
>
> impossible to publish artifacts for
com.test#project-testmodule;working@cuthbes-macbook.local:
java.lang.NullPointerException
>
>
> Is there some debug logging I can put on?
>
>
> On 23 Aug 2010, at 19:55, Ben Cuthbert wrote:
>
>> All
>>
>> I am trying to publish my module and I have the follow tasks
>>
>> <target name="publish-remote-repo" depends=""
>> description="compiles, creates the jar, and then publishes it to the
repo.">
>> <subant target="publish-remote" buildpathref="dist.dir" />
>> </target>
>>
>> And in the common file I have
>>
>> <target name="publish-remote" depends="" description="--> publish this
project in the ivy repository">
>> <ivy:publish artifactspattern="${build.dir}/[artifact].[ext]"
>> resolver="remoterepo-publish"
>> pubrevision="${version}"
>> status="integration"
>> overwrite="true"
>> >
>> <artifacts/>
>> </ivy:publish>
>> <echo message="project ${ant.project.name} released with version
${version}" />
>> </target>
>>
>>
>> But when I call it using ant I get this error
>>
>> cuthbes-macbook:build cuthbe$ ant publish-remote-repo
>> Buildfile: build.xml
>>
>> publish-remote-repo:
>>
>> BUILD FAILED
>> /Users/cuthbe/dev/code/test/build/build.xml:156: Reference dist.dir not
found.
>>
>> Total time: 0 seconds
>> cuthbes-macbook:build cuthbe$
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message