ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Cuthbert <ben_cuthb...@yahoo.co.uk>
Subject Re: Strange deps being downloaded
Date Tue, 10 Aug 2010 13:54:56 GMT
I found the problem is had to do with not setting transitive to false.


On 10 Aug 2010, at 14:20, Andrew McFague wrote:

> Assuming you're using the Ibiblio resolver, yes.  You can load up the 
> Ibiblio page and follow the dependencies yourself, for example, and 
> follow the dependencies.
> 
>     http://mirrors.ibiblio.org/pub/mirrors/maven2/
> 
> Andrew
> 
> On 08/10/10 03:36, Ben Cuthbert wrote:
>> All I have the following dependancies configured in my module
>> 
>>         <dependency org="org.springframework" name="org.springframework.beans"
rev="3.0.3"/>
>>         <dependency org="org.springframework" name="org.springframework.context"
rev="3.0.3"/>
>>         <dependency org="org.springframework" name="org.springframework.core"
rev="3.0.3"/>
>> 
>>         <dependency org="org.jboss" name="netty" rev="3.2.1"/>
>> 
>> When IVy runs I see the following
>> 
>> [ivy:resolve] 		:: commons-beanutils#commons-beanutils;1.7.0!commons-beanutils.jar
>> [ivy:resolve] 		:: org.apache.geronimo.specs#geronimo-jms_1.1_spec;1.0!geronimo-jms_1.1_spec.jar
>> 
>> 
>> But I have not asked it to download jms? Is this because one of the dependancies
requires geronimo?
>> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message