ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bokc bokc <youk...@gmail.com>
Subject Re: Problem with local repository
Date Thu, 03 Jun 2010 07:02:28 GMT
I don't have error from Ivy.
When I do the resolve, Ivy find my Jar :
        found FDI#FDITools;last-build in local
        found FDI#SelligentMapping;last-build in local
But after it don't copy the jar in my ${lib.dir} directory like jar comming
from output repository (maven or jboss).


2010/6/2 Maarten Coene <maarten_coene@yahoo.com>

> What is the exact error message you get from Ivy?
>
> Maarten
>
>
>
> ----- Original Message ----
> From: bokc bokc <youkoun@gmail.com>
> To: ivy-user@ant.apache.org
> Sent: Wed, June 2, 2010 3:59:15 PM
> Subject: Re: Problem with local repository
>
> I found my mistake. I change the Ivy setting to :
> <ivysettings>
>    <properties file="${ivy.settings.dir}/ivysettings.properties" />
>    <property name="myrepository" value="//192.168.100.124/Repository"
> overrite="true"/>
>    <settings defaultResolver="chain-local"/>
>    <resolvers>
>        <chain name="chain-local">
>            <filesystem name="local">
>                <ivy
> pattern="${myrepository}/[module]/[revision]/ivy-[revision].xml" />
>                <artifact
> pattern="${myrepository}/[module]/[revision]/[artifact]-[revision].[ext]"
> />
>            </filesystem>
>            <ibiblio name="maven2" m2compatible="true"/>
>            <ibiblio name="jboss" m2compatible="true" root="
> http://repository.jboss.com/maven2/" />
>        </chain>
>    </resolvers>
> </ivysettings>
>
> So the publication work great but now when I want to use published Jar, Ivy
> say "I found it" but it don't copy jar to the lib directory used for build.
> The other jar comming from maven or jboss repository are coping by Ivy in
> the lib directory without problems.
>
> My build target :
>    <target name="ivy-init" description="Initialisation d'Ivy">
>        <ivy:settings file="${basedir}/ivysettings.xml"/>
>    </target>
>
>    <target name="resolve-compile" depends="ivy-init" description="-->
> retrieve dependencies with ivy">
>        <ivy:resolve file="ivy.xml" type="jar" conf="compile" />
>        <ivy:retrieve pattern="${lib.dir}/[conf]/[artifact].[ext]"
> conf="compile" type="jar"/>
>    </target>
>
> My Ivy file :
> <ivy-module version="2.0"
>            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>            xsi:noNamespaceSchemaLocation=
>                   "http://ant.apache.org/ivy/schemas/ivy.xsd">
>    <info organisation="FDI" module="${ant.project.name}"/>
>    <configurations defaultconfmapping="default" >
>        <conf name="default" />
>        <conf name="compile" extends="default" visibility="public"/>
>    </configurations >
>    <dependencies>
>        <dependency org="log4j" name="log4j" rev="${log4j.version}"
> conf="compile->default" />
>        <dependency org="org.hibernate" name="hibernate-distribution"
> rev="${hibernate.version}" conf="compile->default"/>
>        <dependency org="net.sourceforge.jtds" name="jtds"
> rev="${jtds.version}" conf="compile->default"/>
>        <dependency org="FDI" name="FDITools" rev="${FDITools.version}"
> conf="compile->default" />
>        <dependency org="FDI" name="SelligentMapping"
> rev="${SelligentMapping.version}" conf="compile->default" />
>    </dependencies>
> </ivy-module>
>
> Do you have an idea of the issue?
>
> 2010/6/1 bokc bokc <youkoun@gmail.com>
>
> > Yes, my jar is in ${dist.dir} .
> >
> > The ant log is :
> > publish-local:
> > :: delivering :: FDI#FDITools;working@FR-KUNTZ :: last-build ::
> > integration :: Tue Jun 01 08:50:20 CEST 2010
> >         delivering ivy file to
> > C:\Olivier\dev\Tools\FDITools\scripts\..\dist\ivy.xml
> > :: publishing :: FDI#FDITools
> >         published FDITools to C:\Documents and
> > Settings\kuntz\.ivy2/local/FDI/FDITools/last-build/jars/FDITools.jar
> >         published ivy to C:\Documents and
> > Settings\kuntz\.ivy2/local/FDI/FDITools/last-build/ivys/ivy.xml
> >
> > Olivier
> >
> >
> >
> >
> > 2010/5/31 Maarten Coene <maarten_coene@yahoo.com>
> >
> > Stupid question: is your jar located in ${dist.dir} ?
> >> If so, could you post the Ant console output you get when publishing
> your
> >> jar?
> >>
> >> Maarten
> >>
> >>
> >>
> >>
> >> ----- Original Message ----
> >> From: bokc bokc <youkoun@gmail.com>
> >> To: ivy-user@ant.apache.org
> >> Sent: Mon, May 31, 2010 3:41:37 PM
> >> Subject: Problem with local repository
> >>
> >> Hi all,
> >>
> >> I'm new on Ivy. I try to publish a jar on a local repository (shared
> >> directory).
> >>
> >> My ivy conf file is :
> >> <ivysettings>
> >>    <properties file="${ivy.settings.dir}/ivysettings.properties" />
> >>    <property name="myrepository" value="//192.168.100.124/Repository"
> >> overrrite="true"/>
> >>    <settings defaultResolver="default"/>
> >>    <resolvers>
> >>            <filesystem name="local">
> >>                <ivy
> pattern="${myrepository}/[module]/ivy-[revision].xml"
> >> />
> >>                <artifact
> >> pattern="${myrepository}/[module]/[artifact]-[revision].[ext]" />
> >>            </filesystem>
> >>    </resolvers>
> >>    <include url="${ivy.default.settings.dir}/ivysettings-public.xml"/>
> >>    <include url="${ivy.default.settings.dir}/ivysettings-shared.xml"/>
> >>    <include url="${ivy.default.settings.dir}/ivysettings-local.xml" />
> >>    <include
> url="${ivy.default.settings.dir}/ivysettings-main-chain.xml"/>
> >>    <include
> >> url="${ivy.default.settings.dir}/ivysettings-default-chain.xml"/>
> >>
> >> </ivysettings>
> >>
> >> My ant task is :
> >>    <target name="ivy-init" description="Initialisation d'Ivy">
> >>        <ivy:settings file="${basedir}/ivysettings.xml"/>
> >>    </target>
> >>    <target name="publish-local" depends="jar,ivy-init" description="-->
> >> publish artifacts in the local repository">
> >>        <tstamp>
> >>            <format property="now" pattern="yyyyMMddHHmmss"/>
> >>        </tstamp>
> >>        <ivy:info />
> >>        <ivy:publish
> >>            resolver="local"
> >>            artifactspattern="${dist.dir}/[artifact].[ext]"
> >>            pubrevision="last-build"
> >>            pubdate="${now}"
> >>            status="integration"
> >>            forcedeliver="true"
> >>            overwrite="true"
> >>            />
> >>    </target>
> >>
> >> The build is good but my jar is not in the local repository. Some one
> can
> >> help me?
> >>
> >>
> >> --
> >> Olivier
> >> http://bokc-fr.blogspot.com/
> >>
> >>
> >>
> >>
> >>
> >
> >
> > --
> > Olivier
> > http://bokc-fr.blogspot.com/
> >
>
>
>
> --
> Olivier
> http://bokc-fr.blogspot.com/
>
>
>
>
>


-- 
Olivier
http://bokc-fr.blogspot.com/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message