ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject Re: Ivy 2.1.0 - invalid sha1
Date Tue, 01 Jun 2010 08:58:49 GMT
It looks like you are having the same problem as reported here:
https://issues.apache.org/jira/browse/IVY-1061

What is the default encoding of your environment?

Maarten




----- Original Message ----
From: Olexander Kozlov <ookozlov@gmail.com>
To: ivy-user@ant.apache.org
Sent: Tue, June 1, 2010 10:37:15 AM
Subject: Ivy 2.1.0 - invalid sha1

Hi everyone. I'm evaluating ivy as a dependency manager for my future java
projects. I'm newbie to both ivy and ant. I started to play with ivy and my
first project fails with invalid sha1 while downloading module descriptor.
My ant version is 1.8.0, ivy is 2.1.0 and java is 1.6.0_20. I run Windows XP
Professional SP3 box. Here is my project files:

build.xml:
<project xmlns:ivy="antlib:org.apache.ivy.ant" name="hello-ivy" basedir="."
default="resolve">
   <target name="resolve" description="--> retrieve dependencies with ivy">
      <ivy:retrieve />
   </target>
</project>

ivy.xml:
<ivy-module version="2.0">
   <info organisation="apache" module="hello-ivy"/>
   <dependencies>
      <dependency org="commons-lang" name="commons-lang" rev="2.5"/>
      <dependency org="commons-cli" name="commons-cli" rev="1.2"/>
   </dependencies>
</ivy-module>

When I run ant I got:
Buildfile: D:\x-ivy-test\build.xml

resolve:
[ivy:retrieve] :: Ivy 2.1.0 - 20090925235825 :: http://ant.apache.org/ivy/::
[ivy:retrieve] :: loading settings :: url =
jar:file:/C:/Documents%20and%20Settings/olek/.ant/lib/ivy-2.1.0.jar!/org/apache/ivy/core/settings/ivysettings.xml
[ivy:retrieve] :: resolving dependencies ::
apache#hello-ivy;working@IOKozlov
[ivy:retrieve]  confs: [default]
[ivy:retrieve] :: resolution report :: resolve 781ms :: artifacts dl 0ms

---------------------------------------------------------------------
        |                  |            modules            ||   artifacts
|
        |       conf       | number| search|dwnlded|evicted||
number|dwnlded|

---------------------------------------------------------------------
        |      default     |   2   |   0   |   0   |   0   ||   0   |   0
|

---------------------------------------------------------------------
[ivy:retrieve]
[ivy:retrieve] :: problems summary ::
[ivy:retrieve] :::: WARNINGS
[ivy:retrieve]  problem while downloading module descriptor:
http://repo1.maven.org/maven2/commons-lang/commons-lang/2.5/commons-lang-2.5.pom:
invalid sha1: expected=
  ♥3ikn┤hi2╡░4h32332o2░ll2▒h▒ ☻#s│фф$cа|↕ ↨р¤Т(
computed=1f3bbfd8b71cf5b8741b50df95dac1a2a72ad324 (156ms)
[ivy:retrieve]          module not found: commons-lang#commons-lang;2.5
[ivy:retrieve]  ==== local: tried
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/local/commons-lang/commons-lang/2.5/ivys/ivy.xml
[ivy:retrieve]    -- artifact
commons-lang#commons-lang;2.5!commons-lang.jar:
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/local/commons-lang/commons-lang/2.5/jars/commons-lang.jar
[ivy:retrieve]  ==== shared: tried
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/shared/commons-lang/commons-lang/2.5/ivys/ivy.xml
[ivy:retrieve]    -- artifact
commons-lang#commons-lang;2.5!commons-lang.jar:
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/shared/commons-lang/commons-lang/2.5/jars/commons-lang.jar
[ivy:retrieve]  ==== public: tried
[ivy:retrieve]
http://repo1.maven.org/maven2/commons-lang/commons-lang/2.5/commons-lang-2.5.pom
[ivy:retrieve]  problem while downloading module descriptor:
http://repo1.maven.org/maven2/org/apache/apache/4/apache-4.pom: invalid
sha1: expected=      ♥♣с☺☺  computed=
606b51c4cb2b470dab162ea12fb63b241cb93e91 (16ms)
[ivy:retrieve]  io problem while parsing ivy file:
http://repo1.maven.org/maven2/org/apache/commons/commons-parent/11/commons-parent-11.pom:
Impossible to load parent for
file:/C:/Documents%20and%20Settings/olek/.ivy2/cache/org.apache.commons/commons-parent/ivy-11.xml.original.
Parent=org.apache#apache;4
[ivy:retrieve]  io problem while parsing ivy file:
http://repo1.maven.org/maven2/commons-cli/commons-cli/1.2/commons-cli-1.2.pom:
Impossible to load parent for file:/C:/D
ocuments%20and%20Settings/olek/.ivy2/cache/commons-cli/commons-cli/ivy-1.2.xml.original.
Parent=org.apache.commons#commons-parent;11
[ivy:retrieve]          module not found: commons-cli#commons-cli;1.2
[ivy:retrieve]  ==== local: tried
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/local/org.apache/apache/4/ivys/ivy.xml
[ivy:retrieve]    -- artifact org.apache#apache;4!apache.jar:
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/local/org.apache/apache/4/jars/apache.jar
[ivy:retrieve]  ==== shared: tried
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/shared/org.apache/apache/4/ivys/ivy.xml
[ivy:retrieve]    -- artifact org.apache#apache;4!apache.jar:
[ivy:retrieve]    C:\Documents and
Settings\olek\.ivy2/shared/org.apache/apache/4/jars/apache.jar
[ivy:retrieve]  ==== public: tried
[ivy:retrieve]
http://repo1.maven.org/maven2/org/apache/apache/4/apache-4.pom
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          ::          UNRESOLVED DEPENDENCIES         ::
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          :: commons-lang#commons-lang;2.5: not found
[ivy:retrieve]          :: commons-cli#commons-cli;1.2: not found
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]
[ivy:retrieve]
[ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

BUILD FAILED
D:\x-ivy-test\build.xml:3: impossible to resolve dependencies:
        resolve failed - see output for details

Total time: 1 second

What am I doing wrong?



      

Mime
View raw message