ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject Re: Ivy warnings when accessing local repository setup using namespaces
Date Tue, 15 Jun 2010 19:40:08 GMT
I'm not sure you can safely ignore this warning.
Did you encounter any problems so far?

Maarten




----- Original Message ----
From: "Bailey, Darragh" <dbailey@hp.com>
To: "ivy-user@ant.apache.org" <ivy-user@ant.apache.org>
Sent: Fri, June 11, 2010 7:15:22 PM
Subject: Ivy warnings when accessing local repository setup using namespaces



Setup a local repository using the example from the src/examples directory, and just have
it populated with the exact jars that are required. I made an assumption that when using a
namespace for the repository creation, that once the artifacts were in a acceptable layout,
i.e. commons-lang#commons-lang moved to apache#commons-lang, then the settings file used by
the internal projects wouldn't need to have a reference for the namespace.

Currently it doesn't need it to retreive the artifacts from my local-repository, but I do
get the following warnings:
[ivy:retrieve] :: problems summary ::
[ivy:retrieve] :::: WARNINGS
[ivy:retrieve]  namespace not found for org.apache.wink#wink-server;1.1-incubating: maven2
[ivy:retrieve]  namespace not found for org.apache.wink#wink-common;1.1-incubating: maven2
[ivy:retrieve]  namespace not found for org.slf4j#slf4j-api;1.5.11: maven2
[ivy:retrieve]  namespace not found for org.slf4j#slf4j-jdk14;1.5.11: maven2
[ivy:retrieve]  namespace not found for javax.xml.bind#jaxb-api;2.1: maven2
[ivy:retrieve]  namespace not found for javax.xml.stream#stax-api;1.0-2: maven2
[ivy:retrieve]  namespace not found for javax.activation#activation;1.1: maven2
[ivy:retrieve]  namespace not found for com.sun.xml.bind#jaxb-impl;2.1.4: maven2
[ivy:retrieve]  namespace not found for javax.ws.rs#jsr311-api;1.1: maven2
[ivy:retrieve]  namespace not found for apache#commons-lang;2.3: maven2
[ivy:retrieve]  namespace not found for org.apache.geronimo.specs#geronimo-j2ee_1.4_spec;1.1:
maven2
[ivy:retrieve]
[ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

Am I not using the namespace functionality as intended? Or is this just a side effect that
I should ignore?


--
Regards,
Darragh Bailey

Systems Software Engineer
Hewlett Packard Galway Ltd.

Postal Address:    Hewlett Packard Galway Limited, Ballybrit Business Park, Galway
Registered Office: Hewlett Packard Galway Limited, 63-74 Sir John Rogerson's Quay Dublin 2
Registered Number: 361933 


      

Mime
View raw message