ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sarda Jean-Christophe <jean-christophe.sa...@cnes.fr>
Subject Re: Proxy Authentication Problem
Date Mon, 31 May 2010 08:11:23 GMT
yes, it solves my problem !
thank you very much !

Jean-Christophe.

Le 28/05/2010 00:00, Maarten Coene a écrit :
> ok, the problem only occurred when using Ivy in combination with commons-httpclient.
> I've committed an additional patch in SVN trunk.
>
> Could you give it a try (in combination with commons-httpclient!) to check if it solves
your problem?
>
> thanks,
> Maarten
>
>
>
> ----- Original Message ----
> From: Sarda Jean-Christophe<jean-christophe.sarda@cnes.fr>
> To: ivy-user@ant.apache.org
> Sent: Tue, May 25, 2010 10:41:59 AM
> Subject: Re: Proxy Authentication Problem
>
> Hi,
>
> Sorry for the delay !
>
> I have tried your fix, but I still have the same problem.
> I send you (in joined piece) the console output.
> (For information, the ivy.jar file I tried from the trunk is named
> D:/PUBLIC/dev/workspace/sofcommon/apache-ant-1.7.0/lib/org.apache.ivy_2.1.0.jar)
>
> Thanks,
> Jean-Christophe.
>
>
> Le 21/05/2010 00:04, Maarten Coene a écrit :
>    
>> I might have found a possible issue in the code.
>> I've committed a potential fix in SVN trunk, could you give it a try?
>>
>> thanks,
>> Maarten
>>
>>
>>
>>
>> ----- Original Message ----
>> From: Maarten Coene<maarten_coene@yahoo.com>
>> To: ivy-user@ant.apache.org
>> Sent: Thu, May 20, 2010 10:59:17 PM
>> Subject: Re: Proxy Authentication Problem
>>
>> What is the console output when running Ivy trunk version in verbose (ant -v) mode?
>>
>> Maarten
>>
>>
>>
>>
>> ----- Original Message ----
>> From: Sarda Jean-Christophe<jean-christophe.sarda@cnes.fr>
>> To: ivy-user@ant.apache.org
>> Sent: Thu, May 20, 2010 9:50:27 AM
>> Subject: Proxy Authentication Problem
>>
>> Hi all,
>>
>> I have a problem with the proxy authentication.
>> The retrieve task works fine with the 2.1.0 rc1 version, but does not work with the
2.1.0 final version (and with the trunk version)
>>
>>
>> I am behind a proxy which need authentication.
>>
>> I set the proxy configuration in my build file like that :
>>
>> <setproxy proxyhost="myProxyHost" proxyport="myPortNumber"
>>                           proxyuser="myLogin" proxypassword="myPassword"/>
>>
>>
>> With the 2.1.0 final version, I have some logs like that :
>>
>> ....
>> [ivy:retrieve] INFO: Basic authentication scheme selected
>> [ivy:retrieve] INFO: No credentials available for BASIC 'Identification proxy'@myProxyHost:myPortNumber
>> .....
>> [ivy:retrieve]     Your proxy requires authentication.
>> ...
>>
>> It works fine on 2.1.0 rc1, is there a known regression ?
>>
>> regards,
>> Jean-Christophe
>>
>>
>>
>>
>>      
>
>
>    


Mime
View raw message