ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Imner, Andreas" <Andreas.Im...@kgk.se>
Subject ivy:install fails when directories does not exists (WebDAV)
Date Mon, 08 Mar 2010 15:09:05 GMT

Hi

I am using Apache Ivy 2.1.0

When installing an artifact using ivy:install from public repo to a shared local repository
(stored on an Apache webserver -server using WebDAV), I get the following error from Apache
Ivy

"impossible to install log4j#log4j;1.2.15: java.io.IOException: Access to URL http://infrabuild.infraak.kgk.ad/ivyrepo/log4j/log4j/sources/log4j-1.2.15-sources.jar
was refused by the server:
Forbidden"

The error.log in Apache displays the following
... Unable to PUT new contents for /ivyrepo/log4j/log4j/sources/log4j-1.2.15-sources.jar.
 [403, #0]
... An error occurred while opening a resource.  [500, #0]

The access.log displays the following
"PUT /ivyrepo/log4j/log4j/sources/log4j-1.2.15-sources.jar HTTP/1.1" 403 254

The problem is (my guess) is that the Apache Ivy -client is not creating the directory structure
(using MKCOL) needed before PUT:ing the file? I don't see any MKCOL -requests in the access
log and not any PROPFIND or OPTIONS either?


If I create the directory structure (/ivyrepo/log4j/log4j/sources/) manually on the webserver
and then try ivy:install again, it works fine!?

A strange thing is that this worked fine just a couple of weeks ago?

Regards,

Andreas Imner 
System Developer 
Autokatalogen 



Mime
View raw message