ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Goblirsch <dgoblir...@interactivebrokers.com>
Subject Re: Ivy + hudson CI - problems downloading artifacts, please, help
Date Sun, 28 Feb 2010 17:23:30 GMT
Maarten Coene wrote:
> ok, I've found a place in the Ivy code that could cause the resolve to hang.
> I've fixed that particular problem in SVN trunk. Could you try again with the latest
Ivy code from trunk to see if the problem has been fixed?
>
> thanks,
> Maarten
>
>   

Fixed! I downloaded the jar 2.2.0.20100227220116.jar from your Hudson 
server, and it worked. Thank you so much.

David

>
>
> ----- Original Message ----
> From: David Goblirsch <dgoblirsch@interactivebrokers.com>
> To: ivy-user@ant.apache.org
> Sent: Fri, February 26, 2010 12:28:30 AM
> Subject: Re: Ivy + hudson CI - problems downloading artifacts, please, help
>
> Maarten Coene wrote:
>   
>> I was not aware of any problems with the artifact-lock strategy.
>> Could you provide more details, like for instance the ant output when setting the
property "ivy.log.locking" to "true"
>>
>> Maarten
>>
>>  
>>     
> If I put this line
>
> <caches lockStrategy="artifact-lock"/>
>
> into my Ivy settings file, and then start with a clean slate, i.e,
> having completely cleared the local cache under .ivy2,
> and then run ant 1.7.1 with -Divy.log.locking=true as you suggested, I see that
> ant ends up in an "infinite" loop printing out log messages that say
>
> Thread[main,5,main]   [large integer]  file creation failed  [filename]
>
>   


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message