ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Harrigan <>
Subject Problem publishing sources to local repository
Date Wed, 10 Feb 2010 21:34:45 GMT

(in case of formatting problems, I've put a copy of this email here:

I'm having a problem publishing my sources to a local repo. This is what I have:


    <settings defaultResolver="default" />
    <resolvers m2compatible="true">
        <chain name="default" returnFirst="true" checkmodified="true">
            <ibiblio name="ibiblio" m2compatible="true" />
            <ibiblio name="sourceforge-ehcache" m2compatible="true"
root="" />
            <filesystem name="local">
        <module organisation="net.sf.ehcache" name=".*"
resolver="sourceforge-ehcache" />

my ivy.xml

    <artifact name="myapp" type="jar" ext="jar" />
    <artifact name="myapp-sources" type="source" ext="jar" />

and in my build.xml, I have this:

<target name="publish-locally">
    <ivy:publish resolver="local" organisation=""
module="${}" revision="${dist.version}"
forcedeliver="true" overwrite="true">
pattern="${dist.tmp.dir}/[type]s/[artifact]-[revision].[ext]" />

When I produce my jars I end up with this:


Yet, when I publish, all I end up is with the myapp-0.1.jar

This is the debug output:

[ivy:publish] :: Ivy 2.1.0 - 20090925235825 :: ::
[ivy:publish] :: loading settings :: file =
:: delivering ::;0.1 :: 0.1 :: integration :: Wed Feb 10
22:20:44 CET 2010
	delivering ivy file to
:: publishing ::
	published promoweb to
	published ivy to /Users/fubar/.ivy2/local/

Funnily enough, when I examine the ivy-0.1.xml, I only have this under

    <artifact name="myapp" type="jar" ext="jar" />

I'm really at a loss to understand why this isn't working. I had a
look thru the mailing list, tried a few things
but still no joy :-(

Anyone spot any glaringly obvious error I'm doing?


View raw message