ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Harrigan <dharri...@gmail.com>
Subject A little request for help for a newbie please.
Date Tue, 09 Feb 2010 09:06:59 GMT
Hiya,

I'm trying to figure out how I can get ivy to pull in these deps:

http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/ehcache/ehcache/

In my ivy.xml I have:

<!-- EHCACHE -->
<dependency org="net.sf.ehcache" name="ehcache" rev="2.0.0-SNAPSHOT"
conf="runtime->default"/>
<dependency org="net.sf.ehcache" name="ehcache-core"
rev="2.0.0-SNAPSHOT" conf="runtime->default"/>

I've got an ivysettings.xml configured as:

<ivysettings>
   <settings defaultResolver="ibiblio" />
   <resolvers>
       <ibiblio name="ibiblio" m2compatible="true" />
       <url name="sourceforge-ehcache" m2compatible="true" >
           <ivy
pattern="http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/[module]/[module]/[revision]/ivy-[revision].xml"
/>
           <artifact
pattern="http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/[module]/[module]/[revision]/[artifact]-[revision].[ext]"
/>
       </url>
   </resolvers>
   <modules>
       <module organisation="net.sf.ehcache" name="*"
resolver="sourceforge-ehcache" />
   </modules>
</ivysettings>

However, when I run ivy, I get this error:

[ivy:retrieve]
[ivy:retrieve] :: problems summary ::
[ivy:retrieve] :::: WARNINGS
[ivy:retrieve] 		module not found: net.sf.ehcache#ehcache;2.0.0-SNAPSHOT
[ivy:retrieve] 	==== sourceforge-ehcache: tried
[ivy:retrieve] 	
http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/ehcache/ehcache/2.0.0-SNAPSHOT/ivy-2.0.0-SNAPSHOT.xml
[ivy:retrieve] 	  -- artifact net.sf.ehcache#ehcache;2.0.0-SNAPSHOT!ehcache.jar:
[ivy:retrieve] 	
http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/ehcache/ehcache/2.0.0-SNAPSHOT/ehcache-2.0.0-SNAPSHOT.jar
[ivy:retrieve] 	
http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/ehcache/ehcache/2.0.0-SNAPSHOT/ehcache.jar
[ivy:retrieve] 		module not found: net.sf.ehcache#ehcache-core;2.0.0-SNAPSHOT
[ivy:retrieve] 	==== sourceforge-ehcache: tried
[ivy:retrieve] 	
http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/ehcache-core/ehcache-core/2.0.0-SNAPSHOT/ivy-2.0.0-SNAPSHOT.xml
[ivy:retrieve] 	  -- artifact
net.sf.ehcache#ehcache-core;2.0.0-SNAPSHOT!ehcache-core.jar:
[ivy:retrieve] 	
http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/ehcache-core/ehcache-core/2.0.0-SNAPSHOT/ehcache-core-2.0.0-SNAPSHOT.jar
[ivy:retrieve] 	
http://oss.sonatype.org/content/repositories/sourceforge-snapshots/net/sf/ehcache-core/ehcache-core/2.0.0-SNAPSHOT/ehcache-core.jar
[ivy:retrieve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve] 		::          UNRESOLVED DEPENDENCIES         ::
[ivy:retrieve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve] 		:: net.sf.ehcache#ehcache;2.0.0-SNAPSHOT: not found
[ivy:retrieve] 		:: net.sf.ehcache#ehcache-core;2.0.0-SNAPSHOT: not found
[ivy:retrieve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]
[ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

I've tried playing around with the location of the [module] and
[revision] variable's but can't seem to resolve my problem.

I was wondering if any kind person could help me out please?

Thank you

-=david=-

Mime
View raw message