ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: Oddities adding IvyDE Managed Dependencies library to runtime configuration
Date Sat, 13 Feb 2010 09:21:34 GMT

Le 10 févr. 2010 à 13:50, Steele, Richard a écrit :

> I have IvyDE installed in Eclipse 3.5.  So far I've been pleased with how
> easy things are, but I came across something odd.
> 
> I have an Eclipse project for which I've configured an IvyDE library to
> bring in my compile and test configuration dependencies.  To actually run
> the code, however, we have to use the runtime configuration as well, so I
> opened the Run Configuration for my Java Application, click on the Classpath
> tab, select User Entries (in the tree), click on the Advanced... button to
> add the IvyDE library.
> 
> I select IvyDE Managed Dependencies, but when I click Next> nothing
> happens.  If I click it a second time, I'm presented with a mostly blank
> panel where I would normally choose my configurations; the contents only
> show if I resize the dialog .  Event when I do this none of the
> configuration are listed.
> 
> If I go ahead and click finish, I do get the library but with all
> configurations.  This appears to work, though I'd prefer if I could select
> just the runtime configuration.
> 
> I hope the above description is sufficiently clear.
> 
> Is this a known issue?

Yep, there was issues with launch configuration. It works better in the trunk version, which
is currently being released.
You should be interested by this doc too:
http://ant.apache.org/ivy/ivyde/history/trunk/cpc/launch.html

Nicolas


Mime
View raw message