ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Schwager" <Daniel.Schwa...@dtnet.de>
Subject RE: dependencies failed using branch attribute
Date Wed, 18 Nov 2009 19:17:56 GMT
Hi Carlton,

thanks for this information. I tried your approach
but it does not work for me.

I create a VERY small sample project (build.xml & ivy.xml)
using a sample ivyrepos on our server.

Could somebody look closer to the problem by downloading the project
from
    http://www.opensource-online.org/fileadmin/swd/ivy/ivy-test.zip

To run, yust unzip and start "ant -f build.xml" and you can see the
failure:

[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           :: testng#testng#mybranch1;latest.integration:
java.text.ParseException: inconsistent module descriptor file found in
'http:/
www.opensource-online.org/fileadmin/swd/ivy/testng/testng/5.6/ivy.xml':
bad branch name: expected='mybranch1' found='';
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]
[ivy:resolve] :::: ERRORS
[ivy:resolve]           default: bad branch name found in
http://www.opensource-online.org/fileadmin/swd/ivy/testng/testng/5.6/ivy
.xml: expected='myb
anch1 found=''
[ivy:resolve]
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

May I should file a bug to jira ?

regards
Danny

Mime
View raw message