ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nick.dilauro@inovis.com" <nick.dila...@inovis.com>
Subject RE: where to put credentials for ivy:publish
Date Wed, 04 Nov 2009 18:25:46 GMT
Thanks, but unfortunately that's not it.  If anonymous is set to have no privileges then Artifactory
refuses the deploy and logs the deploy as being refused for 'anonymous'.  If the credentials
actually works I would think it would already be populating the userid, etc by the time the
request gets to Artifactory.  

Nick DiLauro

Inovis Inc.


-----Original Message-----
From: Chris Marks [mailto:topher1120@gmail.com] 
Sent: Wednesday, November 04, 2009 10:03 AM
To: ivy-user@ant.apache.org
Subject: Re: where to put credentials for ivy:publish

Is Artifactory set up to allow anonymous publish?  If so, perhaps it's not
sending a challenge for Ivy to respond to.
Thanks,
topher


On Wed, Nov 4, 2009 at 10:32 AM, nick.dilauro@inovis.com <
nick.dilauro@inovis.com> wrote:

> Thanks for the reply, but that didn't work.  It doesn't seem to matter what
> I put in any of the fields since the whole credentials stanza seems to be
> ignored.  It could be in the wrong place or there could be some default
> overriding it, since Artifactory access log shows that user "anonymous" is
> being used for the deploy.
>
> Nick DiLauro
>
> Inovis Inc.
>
> -----Original Message-----
> From: Maarten Coene [mailto:maarten_coene@yahoo.com]
> Sent: Tuesday, November 03, 2009 11:32 PM
> To: ivy-user@ant.apache.org
> Subject: Re: where to put credentials for ivy:publish
>
> I think the host attribute in your credentials should only contain the
> host:
> <credentials host="alfartifactory" realm="Artifactory Realm"
> username="myuser" passwd="mypwd"/>
>
> Maarten
>
>
>
> ________________________________
> From: "nick.dilauro@inovis.com" <nick.dilauro@inovis.com>
> To: "ivy-user@ant.apache.org" <ivy-user@ant.apache.org>
> Sent: Wed, November 4, 2009 12:45:06 AM
> Subject: where to put credentials for ivy:publish
>
>
> I have an ivy:publish target for which I use an ivysettings.xml
> file, but when I check the artifactory server access log it is using
> "anonymous"
> user and not picking up "myuser".   Is there another
> place where I should put the credentials line?  Seems like it's
> being ignored.  I'm using ivy version 2.1.0 and
> Artifactory version 2.0.8
>
> <ivysettings>
> <settings defaultResolver="my-chain">
> </settings>
>  <property name="ivy.repository.host"
> value="alfartifactory:8080/artifactory"/>
>  <credentials host="http://alfartifactory:8080/artifactory";
> realm="Artifactory Realm" username="myuser" passwd="mypwd"/>
>
> <resolvers>
>  <!-- <properties
> file="ivy.properties"/> -->
>  <chain name="my-chain">
>                <url
> name="my-ivy2">
>                                <artifact
> pattern="http://
> ${ivy.repository.host}/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]";
> />
>                                <artifact
> pattern="http://
> ${ivy.repository.host}/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]";
> />
>                                <artifact
> pattern="http://
> ${ivy.repository.host}/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]";
> />
>                </url>
>   </chain>
>  </resolvers>
> </ivysettings>
>
> Nicholas DiLauro
> Sr. Build Engineer III
> 6425 Christie Ave, Ste 300
> Emeryville, CA 94608
> +1 510.285.5026 direct
> +1 510.285.5026 fax
> Nicholas.DiLauro@inovis.com
> www.inovis.com
>
>
>
>
>

Mime
View raw message