ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <keith.hat...@publishingtechnology.com>
Subject RE: IvyDE, SSH repositories, and Eclipse update
Date Mon, 23 Nov 2009 09:26:18 GMT
Thanks Nicolas and Maarten for your comments.

In fact I have found that IvYDE is working fine in my Eclipse 3.5 install -
as I would expect, it is prompting me for the SSH password to the repository
when required (it isn't in my ivysettings.xml). So I guess that there may be
something broken in my older Eclipse 3.2.2 install. One more reason to
upgrade :)

Keith


-----Original Message-----
From: Maarten Coene [mailto:maarten_coene@yahoo.com] 
Sent: 22 November 2009 22:40
To: ivy-user@ant.apache.org
Subject: Re: IvyDE, SSH repositories, and Eclipse update

I just tried and Ivy works fine with jcraft 0.1.42.
So my guess is that Eclipse provides a version of jcraft older than 0.1.31,
which is the minimum version required for Ivy...

Maarten




----- Original Message ----
From: Nicolas Lalevée <nicolas.lalevee@hibnet.org>
To: ivy-user@ant.apache.org
Sent: Sat, November 21, 2009 8:27:34 PM
Subject: Re: IvyDE, SSH repositories, and Eclipse update


Le 20 nov. 2009 à 13:10, Keith Hatton a écrit :

> Hi all,
> 
> I'm using IvyDE-2.0.0-final and JCraft 0.1.42 in Eclipse 3.2.2. When 
> my project uses a component stored in a repository based on SSH, I get 
> an Eclipse error message 'The resolve job of ivy.xml in [project name] 
> has unexpectedly stopped'. I didn't find anything that looked related in
JIRA.
> Anyone got suggestions on how to get past this? Which version of the 
> JCraft plug-in is recommended for IvyDE?

It seems that the jcraft installed in you Eclipse is not compatible with the
one required by Ivy, and Ivy is still trying to use it. Ivy should be more
conservative about the version of jcraft it is using.
Could you open a bug in Ivy please ?

Currently Ivy is compiled with jcraft 0.1.31. You can try to put that
version in Eclipse. But you will have to remove the 0.1.42, as Ivy doesn't
have any restriction (yet) on the version of jcraft it should use, it can
still pick up the wrong one if both are present.


> 
> This is what's appearing in my Eclipse log.
> 
> !ENTRY org.apache.ivyde.eclipse 4 4 2009-11-20 12:00:10.535 !MESSAGE 
> The resolve job of ivy.xml in '[project name]' has unexpectedly 
> stopped !STACK 0
> java.lang.NoSuchMethodError: 
> com.jcraft.jsch.Session.setDaemonThread(Z)V
> at
> org.apache.ivy.plugins.repository.ssh.SshCache.getSession(SshCache.jav
> a:330)
> at
> org.apache.ivy.plugins.repository.ssh.AbstractSshBasedRepository.getSe
> ssion(
> AbstractSshBasedRepository.java:108)
> at
> org.apache.ivy.plugins.repository.ssh.SshRepository.resolveResource(Ss
> hRepos
> itory.java:82)
> at
> org.apache.ivy.plugins.repository.ssh.SshResource.resolve(SshResource.
> java:1
> 01)
> at
> org.apache.ivy.plugins.repository.ssh.SshResource.exists(SshResource.j
> ava:70
> )
> at
> org.apache.ivy.plugins.resolver.RepositoryResolver.findResourceUsingPa
> ttern(
> RepositoryResolver.java:90)
> at
> org.apache.ivy.plugins.resolver.AbstractPatternsBasedResolver.findReso
> urceUs
> ingPatterns(AbstractPatternsBasedResolver.java:93)
> at
> org.apache.ivy.plugins.resolver.AbstractPatternsBasedResolver.findIvyF
> ileRef
> (AbstractPatternsBasedResolver.java:72)
> at
> org.apache.ivy.plugins.resolver.BasicResolver.getDependency(BasicResol
> ver.ja
> va:222)
> at
> org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.findAllArtifactOnRe
> fresh(
> IvyResolveJob.java:408)
> at
> org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.access$5(IvyResolve
> Job.ja
> va:395)
> at
>
org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob$1.run(IvyResolveJob.java:
> 265)
> 
> 
> 
> Also, if I try to run Eclipse update, it's complaining about the IvyDE
site:
> Unable to access " <http://ant.apache.org/ivy/ivyde/updatesite>
> http://ant.apache.org/ivy/ivyde/updatesite".
>    Error parsing site stream. [White spaces are required between 
> publicId and systemId.]
>    Error parsing site stream. [White spaces are required between 
> publicId and systemId.]

This updatesite doesn't exist anymore, you should use the new one:
http://www.apache.org/dist/ant/ivyde/updatesite

Nicolas


      


Mime
View raw message