ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Sion <bjs...@gmail.com>
Subject Issues with 2.1.0
Date Thu, 15 Oct 2009 11:42:43 GMT
Hi Guys,

I am new to Ivy and I have a few questions with regards to ivy 2.1.0. I have
downloaded ivy 2.1.0 and I am attempting to use it in my build file. I have
created an ivy.xml file however, I am a little confused about the version
attribute of the ivy-module element. If I have the following:

<ivy-module version="2.1.0">
...

Then I get an error "invalid version 2.1.0 in file". If I change to the
version to 2.0 the error goes away. Which is the correct version to use in
this instance and why?

My second query is about the documentation about dependency element on this
page :
http://ant.apache.org/ivy/history/latest-milestone/ivyfile/dependency.html

In the examples it lists this:
<dependency org="jayasoft" name="swtbinding" revision="0.2"/>

however "revision" seems not to be a valid attribute for this element. Is
this a mistake in the documentation or am I missing something.

cheers,
Ben

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message