ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "CÚdric Chabanois" <cedric.chaban...@entropysoft.net>
Subject Overriding a previous definition of ivy:settings with the id 'ivy.instance' is not allowed
Date Mon, 07 Sep 2009 08:00:10 GMT
Hi,

When i use multiple target, I get this :

"
Buildfile: D:\programmation\java\projects\cetl-corecomponents\build.xml
ivyconfigure:
[ivy:configure] DEPRECATED: 'ivy.conf.file' is deprecated, use 
'ivy.settings.file' instead
[ivy:configure] :: Ivy 2.1.0-rc2 - 20090704004254 :: 
http://ant.apache.org/ivy/ ::
[ivy:configure] :: loading settings :: file = 
D:\programmation\java\projects\common\ivy\ivyconf.xml
[ivy:configure] DEPRECATED: 'ivyconf' element is deprecated, use 
'ivysettings' instead 
(file:/D:/programmation/java/projects/common/ivy/ivyconf.xml)
taskdef-cobertura:
[ivy:cachepath] :: resolving dependencies :: 
cobertura#cobertura-caller;working

...
tasks-init:
init:
clean:
ivyconfigure:
BUILD FAILED
D:\programmation\java\projects\common\build-ivy.xml:22: Overriding a 
previous definition of ivy:settings with the id 'ivy.instance' is not 
allowed when using override='notallowed'.
"

This seems to be similar to #IVY-771 
(http://issues.apache.org/jira/browse/IVY-771) but I am using Ivy 2.1.0-rc2 
...

Thanks,

CÚdric 




Mime
View raw message