ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aldo_gg <aldo...@yahoo.com>
Subject Problem with dynamic revisions and maven 2 javax.jdo jdo2-api [2.3-eb, 3.0): not found
Date Wed, 23 Sep 2009 14:33:26 GMT


Problem with dynamic revisions javax.jdo jdo2-api [2.3-eb, 3.0): not found

Ivy can't resolve correctly depency on dynamic revisions when the dinamyc
revision
contains strings as [2.3-eb, 3.0)

The jar is correctly located in the maven repository but ivy can't find it.

I had problemas with revisions with only numbers also but i resolved them 
adding in ivy.xml specific numbers to the top however it doesn't work for
[2.3-eb, 3.0)

Help i am new in IVY.


error message
---------------
[ivy:retrieve] :: Ivy 2.0.0-beta1 - 20071206070608 ::
http://ant.apache.org/ivy/ ::
....
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          ::          UNRESOLVED DEPENDENCIES         ::
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]          :: oracle#ojdbc14_g;10.2.0.4: not found
[ivy:retrieve]          :: org.eclipse.core#org.eclipse.core.runtime;3.2.0:
not found
[ivy:retrieve]          :: org.datanucleus#datanucleus-thirdparty;1.0.1: not
found
[ivy:retrieve]          ::
org.eclipse.equinox#org.eclipse.equinox.registry;3.2.0: not found
[ivy:retrieve]          ::
org.eclipse.equinox#org.eclipse.equinox.common;3.2.0: not found
[ivy:retrieve]          :: javax.jdo#jdo2-api;[2.3-eb, 3.0): not found
[ivy:retrieve]          :: javax.transaction#transaction-api;1.1: not found
[ivy:retrieve]          :: org.eclipse.osgi#org.eclipse.osgi;3.2.0: not
found
[ivy:retrieve]          ::::::::::::::::::::::::::::::::::::::::::::::



ivy.xml
-----------------------------------
<ivy-module version="2.0">
	<info organisation="apache" module="hello-ivy"/>
	<dependencies>
		<dependency org="asm" name="asm"   rev="3.1"/>
	  	<dependency org="log4j" name="log4j"   rev="1.2.8"/>
 	    <dependency org="org.datanucleus" name="datanucleus-core"  
rev="1.1.5"/>
	
		<dependency org="org.datanucleus" name="datanucleus-enhancer"  
rev="1.1.4"/>
		<dependency org="javax.jdo" name="jdo2-api" rev="2.3" />

		<dependency org="org.datanucleus" name="datanucleus-core"  rev="1.1.5"/>
		<dependency org="org.datanucleus" name="datanucleus-rdbms" rev="1.1.5"/>
		<dependency org="org.datanucleus" name="datanucleus-jpa"   rev="1.1.5"/>
		<dependency org="net.sf.ehcache" name="ehcache" rev="1.6.2"/>
	
	    <dependency org="com.thoughtworks.xstream" name="xstream-distribution"
rev="1.3"/>

	</dependencies>
</ivy-module>

ivysettings.xml
------------------------------------
<?xml version="1.0" encoding="ISO-8859-1"?> 
<ivysettings>
<settings defaultResolver="chained"/>
<resolvers> 
    <chain name="chained">

      <ibiblio name="java.net"    root="http://download.java.net/maven/2"
m2compatible="true"/>
      <ibiblio name="datanucleus"
root="http://www.datanucleus.org/downloads/maven2" m2compatible="true"/>
	  <ibiblio name="sourceforge"
root="http://oss.sonatype.org/content/repositories/sourceforge-releases"
m2compatible="true" /> 
	  <ibiblio name="codehaus"   
root="http://oss.sonatype.org/content/groups/codehaus/" m2compatible="true"
/> 
	  <ibiblio name="repo2"    root="http://repo2.maven.org/maven2"
m2compatible="true" /> 
	  <ibiblio name="public"      m2compatible="true" /> 
	  <ibiblio name="ibiblio"     m2compatible="true" /> 
	  
    </chain>

</resolvers> 
</ivysettings>

build.xml
-------------------------------------------
    <target name="resolve" description="--> retrieve dependencies with ivy">    
   
	<ivy:settings file="ivysettings.xml" />
	<ivy:retrieve />    
     </target>
-------------------------------------------
ed and dynamic revisions
-- 
View this message in context: http://www.nabble.com/Problem-with-dynamic-revisions-and-maven-2-javax.jdo-jdo2-api--2.3-eb%2C-3.0%29%3A-not-found-tp25531175p25531175.html
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message