ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Tharp <joshua-th...@alumni.calpoly.edu>
Subject Re: Depedencies in shared repository
Date Tue, 04 Aug 2009 19:21:28 GMT
I believe modifying the installed ivy.xml file will cause your checksums to
fail. You need to put the dependencies in the ivy file before
publishing/installing it.

On Tue, Aug 4, 2009 at 12:11 PM, Paul Grenyer <paul.grenyer@gmail.com>wrote:

> Hi
>
> > On Tue, Aug 4, 2009 at 7:39 PM, Shawn
> > Castrianni<Shawn.Castrianni@halliburton.com> wrote:
> >> If you have control over the ivy.xml for the goodmusic module, then you
> specify that it is dependent on
> >> the commons-lang module.
> >
> > Right, I tried that. Actually modified the ivy-0.1.xml that is
> > installed by ivy:install. It didn't work. I'll got back and try again
> > and post the details of exactly what I did.
>
> So, after installing net.purpletube.goodmusic-0.1.jar in my shared
> repository I have the following structure:
>
> iyv
>  net.purpletube
>    goodmusic
>      ivys
>        ivy-0.1.xml
>        ivy-0.1.xml.md5
>        ivy-0.1.xml.sha1
>      jars
>        goodmusic-0.1.jar
>        goodmusic-0.1.jar.md5
>        goodmusic-0.1.jar.sha1
>
> All fairly standard, right? My ivy-0.1.xml looks like this:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <ivy-module version="1.0">
>        <info organisation="net.purpletube"
>                 module="goodmusic"
>                revision="0.1"
>                 status="release"
>                publication="20090802202349"
>                default="true"
>        />
>        <configurations>
>                <conf name="default" visibility="public"/>
>        </configurations>
>        <publications>
>                <artifact name="goodmusic" type="jar" ext="jar"
> conf="default"/>
>        </publications>
> </ivy-module>
>
> So, what you're suggesting is that I modify it to look like this:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <ivy-module version="1.0">
>        <info organisation="net.purpletube"
>                 module="goodmusic"
>                revision="0.1"
>                 status="release"
>                publication="20090802202349"
>                default="true"
>        />
>        <configurations>
>                <conf name="default" visibility="public"/>
>        </configurations>
>        <publications>
>                <artifact name="goodmusic" type="jar" ext="jar"
> conf="default"/>
>        </publications>
>        <dependencies>
>                <dependency org="commons-lang" name="commons-lang" rev="2.0"
> conf="default"/>
>        </dependencies>
> </ivy-module>
>
> I tried it and after I cleared out my cache and resolved my ivy.xml
> (using IvyDE) the only file that gets added to my project is
> goodmusic-0.1.jar. No sign of commons-lang.jar.
>
> Surely I'm doing something daft and the correct thing to do is obvious?
>
> --
> Thanks
> Paul
>
> Paul Grenyer
> e: paul.grenyer@gmail.com
> w: http://www.marauder-consulting.co.uk
> b: paulgrenyer.blogspot.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message