ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Grenyer <paul.gren...@gmail.com>
Subject Re: Depedencies in shared repository
Date Tue, 04 Aug 2009 19:43:50 GMT
Hi

On Tue, Aug 4, 2009 at 8:21 PM, Joshua
Tharp<joshua-tharp@alumni.calpoly.edu> wrote:
> I believe modifying the installed ivy.xml file will cause your checksums to
> fail. You need to put the dependencies in the ivy file before
> publishing/installing it.

Thanks, I tried that as well, but I'm not sure I'm getting it right. I have:

Temp
  repo
    ivy.xml
    net.purpletube.goodmusic-0.1.jar

and my ivy.xml looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<ivy-module version="1.0">
	<info organisation="net.purpletube"
		module="goodmusic"
		revision="0.1"
		status="release"
		default="true"
	/>
	<configurations>
		<conf name="default" visibility="public"/>
	</configurations>
	<publications>
		<artifact name="goodmusic" type="jar" ext="jar" conf="default"/>
	</publications>
	<dependencies>
    	 <dependency org="commons-lang" name="commons-lang" rev="2.0"
conf="default"/>
	</dependencies>
</ivy-module>

Would you believe that as I was putting this email together and trying
it again, it has almost worked! The ivy-0.1.xml in my shared
repository now includes the dependency on commons-lang.jar. And
commons-lang.jar got installed too, which I'm not sure I want!

However, when I run Ivy, at the command line this time I get an error.
I think it might be of my own doing, so I'll investigate further
before i waste any more of anyone's time.



-- 
Thanks
Paul

Paul Grenyer
e: paul.grenyer@gmail.com
w: http://www.marauder-consulting.co.uk
b: paulgrenyer.blogspot.com

Mime
View raw message