ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject Re: What does error message "impossible to get artifacts when data has not been loaded" mean?
Date Mon, 03 Aug 2009 21:10:37 GMT

It is an internal error in Ivy.
Please open a JIRA issue with as much detail as possible (your ivy file, settings, stacktrace,
ant log, ...) and if possible also add a reproduceable scenario to it.

Maarten




----- Original Message ----
From: Gareth Western <gareth@garethwestern.com>
To: ivy-user@ant.apache.org
Sent: Monday, August 3, 2009 4:06:54 PM
Subject: What does error message "impossible to get artifacts when data has  not been loaded"
mean?

Since I started using the release candidates for Ivy 2.1 I've seen the
following error a few times, but I don't know what it means. Thus far
I've managed to get around it by various incantations, such as
cleaning the cache and restarting the build scripts, but it would be
better if I actually knew what was causing the error. Can anyone
provide some more information?

The latest version I'm seeing is this:

impossible to get artifacts when data has not been loaded. IvyNode =
commons-lang#commons-lang;2.1
java.lang.IllegalStateException: impossible to get artifacts when data
has not been loaded. IvyNode = commons-lang#commons-lang;2.1
    at org.apache.ivy.core.resolve.IvyNode.getArtifacts(IvyNode.java:756)
    at org.apache.ivy.core.resolve.IvyNode.getSelectedArtifacts(IvyNode.java:733)
    at org.apache.ivy.core.report.ResolveReport.setDependencies(ResolveReport.java:235)
    at org.apache.ivy.core.resolve.ResolveEngine.resolve(ResolveEngine.java:236)
    at org.apache.ivy.core.resolve.ResolveEngine.resolve(ResolveEngine.java:193)
    at org.apache.ivy.Ivy.resolve(Ivy.java:502)
    at org.clarent.ivyidea.resolve.DependencyResolver.resolve(DependencyResolver.java:77)
    at org.clarent.ivyidea.resolve.IntellijDependencyResolver$1.run(IntellijDependencyResolver.java:60)
    at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:160)
    at org.clarent.ivyidea.resolve.IntellijDependencyResolver.resolve(IntellijDependencyResolver.java:56)
    at org.clarent.ivyidea.ResolveForActiveModuleAction$1.doResolve(ResolveForActiveModuleAction.java:55)
    at org.clarent.ivyidea.intellij.task.IvyIdeaResolveBackgroundTask.run(IvyIdeaResolveBackgroundTask.java:70)
    at com.intellij.openapi.progress.impl.ProgressManagerImpl$5.run(ProgressManagerImpl.java:3)
    at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:6)
    at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:3)
    at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:72)
    at com.intellij.openapi.progress.impl.ProgressManagerImpl$6.run(ProgressManagerImpl.java:11)
    at com.intellij.openapi.application.impl.ApplicationImpl$5.run(ApplicationImpl.java:1)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
    at java.lang.Thread.run(Thread.java:619)
    at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:7)


The funny thing is I don't think I have any dependencies on
commons-lang;2.1 declared anywhere, only 2.4...

PS The references to an "intellij" package are because this error is
now occuring from an Intellij plugin I'm using (IvyIDEA), however I
have been getting the same error message when calling Ivy from an Ant
task as well...



      

Mime
View raw message