ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Re: IvyDE depending on IVY 2.0.0 instead
Date Tue, 14 Jul 2009 14:01:08 GMT

Le 12 juil. 09 à 16:10, Michael Finney a écrit :

>
> Hi,
>
> 1) Any problem with making the IvyDE (2.0.0.beta1) depend on IVY 2.0.0
> instead of Ivy 2.1.0RC1?

You should be able to manually to it into your Eclipse. Just remove  
the Ivy installed in your plugins directory of your Eclipse install  
and the one you want in there.

>
> 2) Any problem with making an eclipse feature without a timestamp in  
> its
> name (it seemed to work)?

Timestamps are somehow mandatory as they make Eclipse understand which  
one is after the other. Without them it may work on the end user side,  
but for the developpers or even some contributor it will be a pain.

>
> We wanted our IvyDE to use IVY 2.0.0.  So we copied/changed features  
> so
> ivyde depends on IVY 2.0.0. this included creating a "feature" for  
> the IVY
> 2.0.0 jar.

Actually features are only needed for updatesite management within  
Eclipse. Just putting the plugins you want into your plugins folder  
should work nicely.

I understand this is not user friendly, so there is:
https://issues.apache.org/jira/browse/IVYDE-185

Nicolas


Mime
View raw message