ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From crashmeister <nabble2...@3dpilots.com>
Subject Error looking for jboss-seam.ejb
Date Mon, 20 Jul 2009 19:31:24 GMT

When trying to use Seam, IVY does not translate the POM 'ejb' packaging to
type="ejb' ext="jar". This causes IVY to look for jboss-seam.ejb instead of
jboss-seam.jar.

-------------

>From 'original' for jboss-seam-debug:

<modelVersion>4.0.0</modelVersion>
  <groupId>org.jboss.seam</groupId>
  <artifactId>jboss-seam-debug</artifactId>
  <parent>
    <groupId>org.jboss.seam</groupId>
    <artifactId>parent</artifactId>
    <version>2.1.2</version>
  </parent>
  <dependencies>
    <dependency>
      <groupId>org.jboss.seam</groupId>
      <artifactId>jboss-seam</artifactId>
      <type>ejb</type>                                        <====
    </dependency>

Translated:
  <dependency org="org.jboss.seam" name="jboss-seam" rev="2.1.2"
force="true" conf="compile->compile(*),master(*);runtime->runtime(*)">
    <artifact name="jboss-seam" type="ejb" ext="ejb" conf=""/>                     
   
<====
</dependency>

---------------

Is there a workaround for this?  

Any ideas when it will be fixed ?



-- 
View this message in context: http://www.nabble.com/Error-looking-for-jboss-seam.ejb-tp24576072p24576072.html
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message