ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fnord <li...@libertylost.org>
Subject Publishing and resolving multiple artifacts
Date Tue, 07 Jul 2009 21:33:11 GMT

I have followed the documentation on how to implement this, but I must be
missing something. I have this in the ivy.xml for the dependent libs:

    <info organisation="someplace" module="Core-libs"/>
     <configurations defaultconfmapping="default->default">
         <conf name="default" />
     </configurations>
     <publications>
    	<artifact name="Core_client" type="jar"  conf="default" ext="jar"/>
    	<artifact name="Core_lib" type="jar"  conf="default" ext="jar"/>
    	<artifact name="Core" type="har"  conf="default" ext="har"/>
    	<artifact name="Core" type="jar"  conf="default" ext="jar"/>
    	<artifact name="Core" type="sar"  conf="default" ext="sar"/>
    </publications>

All of the artifacts publish properly, and appear in my maven repository
(Archiva), with a revision of "LATEST". 

However, when I try to resolve them, it's bombing. 

The ivy.xml for the sub-build has:

    <info organisation="someplace" module="DAD"/>
     <configurations defaultconfmapping="default->default">
         <conf name="default" />
     </configurations> 

        <dependency org="someplace" name="Core-libs" conf="default"
rev="LATEST"/>

I've also tried:

        <dependency org="someplace" name="Core-libs" conf="default->default"
rev="LATEST"/>

My resolve target is:

      <target name="resolve" description=" retrieve the dependencies with
Ivy">
          <ivy:settings file="${ivy.settings.dir}/ivysettings.xml" />
	  <ivy:resolve file="${ant.dir}/ivy.xml" transitive="false" />
          <ivy:retrieve pattern="${lib.dir}/[artifact].[ext]"/>
      </target>

The result is:

[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]           module not found: someplace#Core-libs;LATEST
[ivy:resolve]   ==== ibiblio: tried
[ivy:resolve]    
http://ivy.corp.someplace.pvt:8090/archiva/repository/internal/someplace/Core-libs/LATEST/Core-libs-LATEST.pom
[ivy:resolve]     -- artifact someplace#Core-libs;LATEST!Core-libs.jar:
[ivy:resolve]    
http://ivy.corp.someplace.pvt:8090/archiva/repository/internal/someplace/Core-libs/LATEST/Core-libs-LATEST.jar
[ivy:resolve]   ==== internal: tried
[ivy:resolve]    
/Users/me/Documents/engineering_cleaned/DAD/trunk/ivysettings/repository/someplace/Core-libs/ivy.LATEST.xml
[ivy:resolve]     -- artifact someplace#Core-libs;LATEST!Core-libs.jar:
[ivy:resolve]    
/Users/me/Documents/engineering_cleaned/DAD/trunk/ivysettings/repository/someplace/Core-libs/jars/Core-libs.LATEST.jar
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           :: someplace#Core-libs;LATEST: not found
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::

So for some reason it's looking for a single jar file, not for all of the
individual libs which were published. There is no .pom file published, but I
believe that's normal.

Any idea what I'm doing wrong?


thanks,
fnord
-- 
View this message in context: http://www.nabble.com/Publishing-and-resolving-multiple-artifacts-tp24381751p24381751.html
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message