ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Benton" <jben...@objectreservoir.com>
Subject latest.milestone results in unresolve dependencies
Date Fri, 24 Jul 2009 23:30:12 GMT
I have three repositories, one for integration, one for milestone and
one for release.  When using latest.milestone as my dependency revision
I get an unresolved dependency.  

 

Running in debug mode, I can see that the version matcher with this
message:

 

shared-milestone: default md rejected by version matcherrequiring module
descriptor:
d:\jbenton\work\ivy\rev-test\ivy\shared-milestone\or\my-module\2.0\texts
\my-module.txt (2.0)

                tried [2.0 (MD)]

 

 

How do I define a non-default module descriptor?

 

<ivy-module version="2.0">

   <info organisation="or" module="my-module" revision="2.0"
status="milestone" publication="20090601000000">

   </info>

   <publications>

      <artifact name="my-module" type="text" ext="txt" />

   </publications>

</ivy-module>

 

-- Jeff

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message