ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Resheim, Torkild Ulvoy" <>
Subject Problem with publish using Ivy and Nexus
Date Thu, 11 Jun 2009 13:59:29 GMT
Hi all,

For a few hours I've been struggling getting my ANT script publish to a Nexus repository using
Ivy. The end of log looks something like this:

Overriding previous definition of property "ivy.version"
Overriding previous definition of property "ivy.version"
Overriding previous definition of property "ivy.version"
 [property] Loading C:\DOCUME~1\TURESH~1\LOCALS~1\Temp\
 [property] Unable to find property file: C:\DOCUME~1\TURESH~1\LOCALS~1\Temp\
:: delivering :: packages.win32.win32.x86#avrasm2;2.1.38 :: 2.1.38 :: integration :: Thu Jun
11 15:57:28 CEST 2009
        delivering ivy file to C:\Workspaces\AVR32_Studio\avr-assembler\src\avrasm2.xml
:: publishing :: packages.win32.win32.x86#avrasm2
11.jun.2009 15:57:28 org.apache.commons.httpclient.auth.AuthChallengeProcessor selectAuthScheme
INFO: Basic authentication scheme selected

C:\Workspaces\AVR32_Studio\avr-assembler\build.xml:56: impossible to publish artifacts for
packages.win32.win32.x86#avrasm2;2.1.38: PUT operation to URL
apshots/packages/win32/win32/x86/avrasm2/2.1.38/avrasm2-2.1.38.exe failed with status code
        at org.apache.ivy.ant.IvyPublish.doExecute(

For some reason Nexus says error 400 when attempting to upload and I cannot see why. I was
wondering if someone have had similar experiences.
Torkild Ulvøy Resheim
Senior Design Engineer, AVR Tools
Atmel Norway 

View raw message