ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Archie Cobbs <archie.co...@gmail.com>
Subject Re: Configuration not found
Date Fri, 26 Jun 2009 14:40:42 GMT
That does seem weird. Try flushing your cache (rm -rf ~/.ivy2/cache) and
verify that you are really pulling jaxb from the repository that you think
you are.

-Archie

On Fri, Jun 26, 2009 at 3:06 AM, Dima, Alina <
alina.dima@immobilienscout24.de> wrote:

> Hi all,
>
>
>
> I have a problem with my configurations. I have a module that depends on
> the jaxb library. In my module's Ivy.xml, I declare the dependency:
>
>
>
> <dependencies>
>
>    <dependency name="jaxb" rev="latest.integration" org="sun"
> conf="compile->compile"/>
>
> </dependencies>
>
>
>
> In the ivy.xml from jaxb, I have the following:
>
>
>
> <ivy-module version="1.1">
>
>    <info organisation="sun" module="jaxb" revision="2.1.5"
> status="release" publication="20080625162100">
>
>        <license name="Sun"/>
>
>        <description homepage="http://java.sun.com/webservices/jaxb">
>
>             JavaTM Architecture for XML Binding, Reference
> Implementation
>
>        </description>
>
>    </info>
>
>
>
>    <configurations>
>
>        <conf name="runtime" />
>
>        <conf name="compile" extends="runtime" description="provides the
> compiler" />
>
>    </configurations>
>
>
>
>    <publications>
>
>        <artifact name="jaxb-api" type="jar" conf="runtime"/>
>
>        <artifact name="jaxb-impl" type="jar" conf="runtime"/>
>
>        <artifact name="jaxb-xjc" type="jar" conf="compile"/>
>
>    </publications>
>
>
>
>    <dependencies>
>
>        <dependency org="sun" name="jaf" rev="1.0.2"
> conf="compile->default;runtime->default" />
>
>        <dependency org="sun" name="sjsxp" rev="1.0"
> conf="compile->default;runtime->default" />
>
>    </dependencies>
>
> </ivy-module>
>
>
>
> However, the resolve for my module fails with the following message:
>
>
>
> problems summary ::
>
> [ivy:resolve] :::: WARNINGS
>
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>
> [ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
>
> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>
> [ivy:resolve]           :: sun#jaxb;2.1.5: configuration not found in
> sun#jaxb;2
>
> .1.5: 'compile'.
>
>
>
> Why is this happening? The compile configuration clearly exists for my
> jaxb. And for the 2 dependencies of jaxb it is anyhow mapped to
> default...
>
>
>
> If anyone could help me out, I would really appreciate it a lot!
>
>
>
> Thanks a lot
>
> Alina
>
>


-- 
Archie L. Cobbs

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message