ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Tharp <joshua-th...@alumni.calpoly.edu>
Subject Transitive dependencies not resolving
Date Sat, 23 May 2009 03:42:02 GMT
I've got a private repository based on IvyRoundup. I've put the JBoss client
jars in it, but the transitive dependencies in my ivy file are not
resolving. On the other hand with the same configuration and build script, I
do get the transitive dependencies for apache commons-httpclient.

Here's the ivy.xml file for commons-httpclient (some boiler plate removed)
===================

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" href="../../../../xsl/ivy-doc.xsl"?>
<ivy-module xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
version="2.0" xsi:noNamespaceSchemaLocation="../../../../xsd/ivy.xsd">
    <info organisation="org.apache.commons"
module="commons-httpclient" revision="3.1" status="release"
publication="20070821120000">
        <license name="Apache License, Version 2.0"
url="http://www.apache.org/licenses/LICENSE-2.0"/>
        <ivyauthor name="$Id: ivy.xml 247 2008-05-29 22:06:44Z
archie.cobbs $"
url="http://code.google.com/p/ivyroundup/source/browse${ivyroundup.svn.url}/src/modules/org.apache.commons/commons-httpclient/3.1/"/>
        <repository
pattern="http://ivyroundup.googlecode.com/svn/trunk/repo/modules/[organisation]/[module]/[revision]/ivy.xml"
ivys="true" url="http://ivyroundup.googlecode.com/"
name="ivyroundup"/>
        <description homepage="http://hc.apache.org/httpclient-3.x/">

        </description>

    </info>
    <publications>
        <artifact/>
    </publications>
    <dependencies>
        <dependency org="org.apache.commons" name="commons-logging"
rev="[1.0.4,2.0[" conf="default->default"/>
        <dependency org="org.apache.commons" name="commons-codec"
rev="[1.2,2.0[" conf="default->default"/>
    </dependencies>

</ivy-module>



And here's the ivy.xml for the JBoss-client jars
===================

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" href="../../../../xsl/ivy-doc.xsl"?>
<ivy-module xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
version="2.0" xsi:noNamespaceSchemaLocation="../../../../xsd/ivy.xsd">
  <info organisation="org.jboss" module="jboss-client"
revision="5.0.1.GA" status="release" publication="20090224043700">
        <ivyauthor name="$Id: $"
url="http://code.google.com/p/ivyroundup/source/browse${ivyroundup.svn.url}/src/modules/org.jboss/jboss-client/5.0.1.GA/"/>
        <repository
pattern="http://ivyroundup.googlecode.com/svn/trunk/repo/modules/[organisation]/[module]/[revision]/ivy.xml"
ivys="true" url="http://ivyroundup.googlecode.com/"
name="ivyroundup"/>
        <description>The JBoss client jar files.</description>
    </info>
  <configurations>
    <conf name="core"/>
    <conf name="naming" extends="core"/>
    <conf name="jms" extends="naming"/>
    <conf name="default" extends="jms"/>
  </configurations>

  <publications>
    <!-- Core artifacts -->
    <artifact name="jboss-logging-spi" conf="core"/>

    <!-- Naming artifacts -->
    <artifact name="jnp-client" conf="naming"/>

    <!-- JMS artifacts -->
    <artifact name="jboss-aop-client" conf="jms"/>
    <artifact name="jboss-common-core" conf="jms"/>
    <artifact name="jboss-iiop-client" conf="jms"/>
    <artifact name="jboss-mdr" conf="jms"/>
    <artifact name="jboss-messaging-client" conf="jms"/>
    <artifact name="jboss-remoting" conf="jms"/>
    <artifact name="jboss-serialization" conf="jms"/>
  </publications>

  <dependencies>
    <dependency name="javassist" org="org.jboss" rev="3.9.0"
conf="jms->default"/>
    <dependency name="trove" org="net.sourceforge.trove4j" rev="1.0.2"
conf="jms->default"/>
    <dependency name="concurrent" org="edu.oswego.cs.gee" rev="1.3.4"
conf="jms->default"/>
    <dependency name="log4j" org="org.apache.log4j" rev="1.2.15"
conf="jms->default"/>
  </dependencies>
</ivy-module>

I'm trying to resolve the configuration "jms". I get the artifacts declared
in the publications section, but none of the dependencies show up.

Any ideas?

Thanks,

Josh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message