ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Tharp <joshua-th...@alumni.calpoly.edu>
Subject Re: Ivy newbie and Nexus repository
Date Fri, 22 May 2009 16:54:45 GMT
Unless you have altered your nexus installation, I think your base URL
should actually be http://devlinux01:0801/nexus/content/groups/public

Josh

On Fri, May 22, 2009 at 9:49 AM, Jim Garrison <Jim.Garrison@troux.com>wrote:

> Total Ivy newbie here trying to set up a Nexus repository.  A forum
> search turned up the following:
>
> > Add a new resolver
> > <ivysettings>
> >         <resolvers>
> >                 <ibiblio name="public" m2compatible="true" \
> > root="${ivy.ibiblio.default.artifact.root}"/>  </resolvers>
> > </ivysettings>
> >
> > And use ivy.ibiblio.default.artifact.root to point to correct repository
> ( your nexus \
> > repository)
>
> However, I'm not sure of the format of the the URL to point to the
> nexus repository.  I tried adding the following to build.xml
>
> <property name="ivy.ibiblio.default.artifact.root" value="
> http://devlinux01:8081/nexus" />
>
> The URL points to the Nexus server, but this didn't work:
>
> [ivy:retrieve] :::: ERRORS
> [ivy:retrieve]  unknown resolver null
> [ivy:retrieve]  no resolver found for commons-lang#commons-lang: check your
> configuration
> [ivy:retrieve]  unknown resolver null
> [ivy:retrieve]  no resolver found for commons-cli#commons-cli: check your
> configuration
>
> Here's my ivysettings.xml:
>
> <ivysettings>
>  <resolvers>
>    <ibiblio name="public" m2compatible="true"
> root="${ivy.ibiblio.default.artifact.root}"/>
>  </resolvers>
> </ivysettings>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message