ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Tharp <joshua-th...@alumni.calpoly.edu>
Subject Re: Cache not update
Date Tue, 19 May 2009 15:42:35 GMT
My publish task looks like this:
  <ivy:publish
      update="true"
      artifactspattern="${o.dist.d}/[artifact].[ext]"
      resolver="local"
      pubrevision="${my.local.revision}"
      forcedeliver="true"
      overwrite="true" />

I think the forcedeliver is what you two are looking for.

On Tue, May 19, 2009 at 8:14 AM, Bieringer, Dominik <
dbieringer@thegoldensource.com> wrote:

> I had the same problem. I got it resolved by also updating the publication
> timestamp in the ivy.xml file ;).
>
> -----Original Message-----
> From: Gilles Sadowski [mailto:gilles@harfang.homelinux.org]
> Sent: Tuesday, May 19, 2009 17:16
> To: ivy-user@ant.apache.org
> Subject: Re: Cache not update
>
> Hi.
>
> >
> > I have a problem when retrieving artifacts from a filesystem repository.
> Ivy is always using the file from the cache even if there is a more recent
> version in the repository. I tried several ways to force Ivy to update the
> cache, but none of them have any effect. Therefore I assume that this is a
> bug in ivy. What I tried so far:
> >
> > - changing=true on the dependency in ivy.xml
> > - checkModified=true on the filesystem resolver in ivysettings.xml
> > - changingPattern=".*" on the filesystem resolver
> >
> > [...]
> >
> > As a workaround, I am deleting the cache before every resolve.
>
> I have posted a message reporting this exact same problem. I had tried the
> same things, and currently use the same inefficient or error-prone
> workaround. Needless to say that I'm also very interested in having this
> sorted out (whether bug or feature requiring some appropriate config).
>
> Gilles
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message